6 Replies Latest reply on Mar 6, 2013 10:43 PM by Thomas Setiabudi

    How to change the Port of JBPM5.3 Full Installer?

    Thomas Setiabudi Expert

      Hi,

       

      I Used JBPM5.3 Full Installer, it works well with the default configuration

      My question is how do we change the default sample which works at localhost:8080 to some other port?

       

      So far, I have changed:

      1. {installerPath}\jboss-as-7.0.2.Final\standalone\configuration\standalone.xml

       

      changing the port value in this part

      <socket-binding-group name="standard-sockets" default-interface="public">

              <socket-binding name="http" port="8082"/>

       

      doing this, i can access the jbpm console but the console is unable to load any process from guvnor repository

       

      2.  {installerPath}\guvnor.preferences.properties

      changed port 8080 to 8082

       

      3. {installerPath}\jbpm.console.properties

      changed port 8080 to 8082

       

      4.  {installerPath}\jboss-as-7.0.2.Final\standalone\deployments\drools-guvnor.war\WEB-INF\classes\preferences.properties

      changed port 8080 to 8082

       

      5. {installerPath}\jboss-as-7.0.2.Final\standalone\deployments\jbpm-gwt-console-server.war\WEB-INF\classes\guvnor.preferences.properties

      changed port 8080 to 8082

       

      6. {installerPath}\jboss-as-7.0.2.Final\standalone\deployments\jbpm-gwt-console-server.war\WEB-INF\classes\jbpm.console.properties

      changed port 8080 to 8082

       

      but still no success, now when i try to refresh the list of process definition in jbpm console I always get the resteasy error.

       

      I suppose there should be some other files that need to be modified. Which files are those?

       

      Any Help is appreciated.

       

       

      Regards,

      Thomas Setiabudi

        • 1. Re: How to change the Port of JBPM5.3 Full Installer?
          le_roy Newbie

          I'm new to jBPM too, but I found if you change the ports in ${JBPM_HOME}/build.xml before you do ant install.demo[.noeclipse] you might have better luck.

          I've also tried going down the route you're describing changing it in all the deployed apps, but I get resteasy stack traces that way too.

          • 2. Re: How to change the Port of JBPM5.3 Full Installer?
            Thomas Setiabudi Expert

            Hi Le_Roy,

             

            Thank you for your reply.

             

            I haven't tried changing the port and re run the ant install.

             

            I suppose there should be a way to do this without re running the install script?

             

             

            Regards,

            Thomas Setiabudi

            • 3. Re: How to change the Port of JBPM5.3 Full Installer?
              Ju Lee Newbie

              Hi all,

               

              There is an article at this link http://bpmgeek.com/blog/how-change-default-portslistening-address-jbpm5

              I follow this but I meet the same problem like you. Do you have sth news for this topic, Thomas & Ie_roy ?

              • 4. Re: How to change the Port of JBPM5.3 Full Installer?
                Thomas Setiabudi Expert

                hi Lee Yoo,

                 

                take a look here: https://community.jboss.org/message/793230#793230

                 

                Places where you need to make changes is:

                A. Your jboss AS standalone.xml

                 

                B.  designer.war

                      go to designer.war\profiles\jbpm.xml

                      change the guvnor port in  <externalloadurl protocol="http" host=....

                 

                C. drools-guvnor.war

                    go to drools-guvnor.war\WEB-INF\classes\preferences.properties

                    change the port in

                     designer.url=

                     formbuilder.url=

                 

                D. jbpm-form-builder.war

                    go to jbpm-form-builder.war\WEB-INF\springComponents.xml

                    change the port number in

                     <bean id="guvnorUrl" class="java.lang.String">
                      <constructor-arg type="java.lang.String" value=

                 

                E. jbpm-gwt-console-server.war

                     go to jbpm-gwt-console-server.war\WEB-INF\classes\default.jbpm.console.properties

                     adjust the setting for

                     jbpm.console.server.host=

                     jbpm.console.server.port=

                     jbpm.console.task.service.host=

                     jbpm.console.task.service.port=

                     guvnor.host=

                 

                     go to  jbpm-gwt-console-server.war\WEB-INF\classes\guvnor.preferences.properties

                     adjust the setting for

                     designer.url=

                     formbuilder.url=

                 

                F. jbpm-human-task-war.war

                     go to jbpm-human-task-war.war\WEB-INF\web.xml

                     adjust the setting for

                     <param-name>hornetq.host</param-name>

                     and also

                     <param-name>hornetq.port</param-name>

                 

                And lastly make sure that your new port is not used by other application / service.

                 

                it works for JBPM5.4

                 

                 

                Regards,

                Thomas Setiabudi

                • 5. Re: How to change the Port of JBPM5.3 Full Installer?
                  sharatgunnala Newbie

                  Hi Thomas,

                   

                  I am working with the JBPM 5.4 demo setup. and I did tried to change the port and did update all the files as specified except some of those where I couldnt find the variable specified.

                  I did restart the server and I have trouble with the Webdesigner and it just says JBPM Web designer loading  and ihn the drools I can design the process and when I try to save and it fails, clearly seems that repository connection is failing but could not figure out where to change the setting.

                   

                  Please suggest.

                   

                  Thanks

                  • 6. Re: How to change the Port of JBPM5.3 Full Installer?
                    Thomas Setiabudi Expert

                    Hi sharatgunnala,

                     

                    have you double checked:

                    B.  designer.war

                          go to designer.war\profiles\jbpm.xml

                          change the guvnor port in  <externalloadurl protocol="http" host=....

                     

                    C. drools-guvnor.war

                        go to drools-guvnor.war\WEB-INF\classes\preferences.properties

                        change the port in

                         designer.url=

                         formbuilder.url=