1 Reply Latest reply on Oct 12, 2012 7:50 AM by Stefan Miklosovic

    blank screen after deploying errai-jpa demo examples

    Stefan Miklosovic Novice

      Hi,

       

      after successful deploying to the AS (JBoss AS 7 and EAP 6.0.0 too) and trying the address http://localhost:8080/errai-jpa-demo-grocery-list/, all I can see is the white blank page and application as such is not displaying to me. It does not matter if I try firefox or chrome (at linux), the result is the same - blank white screen.

       

      It is worth to mention that errai-jpa-demo-basic works well only in firefox, chrome displays blank screen to me.

       

      I don't know if that can be a case but while deploying the application war file, this error message shows:

       

      13:13:15,240 WARN  [org.jboss.as.ee] (MSC service thread 1-8) JBAS011006: 
      Not installing optional component org.jboss.errai.bus.server.servlet.StandardAsyncServlet$1 due to exception: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011054: 
      Could not find default constructor for class org.jboss.errai.bus.server.servlet.StandardAsyncServlet$1
                at org.jboss.as.ee.component.ComponentDescription$DefaultComponentConfigurator.configure(ComponentDescription.java:606)
                at org.jboss.as.ee.component.deployers.EEModuleConfigurationProcessor.deploy(EEModuleConfigurationProcessor.java:81)
                at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
                at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_35]
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_35]
                at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_35]
      

       

      I checked the sources and there is really not a default constructor for that class org.jboss.errai.bus.server.servlet.StandardAsyncServlet.

       

      Maybe it does not solve the issue, but it would be nice to make the default constructor and get rid of that error message which only confuses people ...