1 Reply Latest reply on Oct 17, 2012 2:41 PM by Phillip Rhodes

    [SOLVED] "No ClassLoaders found for: org.jboss.jms.server.connectionfactory.ConnectionFactory" error, Unified Invoker, JBoss 4.2.3.GA

    Phillip Rhodes Newbie

      Hi all, I'm having an issue with JBoss 4.2.3 and the Unified Invoker.  I have a completely vanilla JBoss 4.2.3.GA install, and have followed the instructions at

      https://community.jboss.org/wiki/EJBJMSAndJNDIOverHTTPWithUnifiedInvoker

      to install and configure the unified invoker.  I downloaded the http-uinvoker-v2.sar.zip and

      extracted it into my deploy dir, and copied the naming related classes per the docs.  The only thing

      I did not do is the ssl certificate bit, since I only care about getting basic http working at first (I will

      want SSL working, but I want to satisfy myself that I can get basic http working first).

       

      Now, when I try to start the server, I receive the following error:

       

       

      --- Incompletely deployed packages ---

      org.jboss.deployment.DeploymentInfo@63fd0baf { url=file:/usr/servers/jboss-4.2.3.GA/server/uinvoker/deploy/http-uinvoker.sar/ }

        deployer: org.jboss.deployment.SARDeployer@30e3c624

        status: Deployment FAILED reason: No ClassLoaders found for: org.jboss.jms.server.connectionfactory.ConnectionFactory; - nested throwable: (java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.jms.server.connectionfactory.ConnectionFactory)

        state: FAILED

        watch: file:/usr/servers/jboss-4.2.3.GA/server/uinvoker/deploy/http-uinvoker.sar/META-INF/jboss-service.xml

        altDD: null

        lastDeployed: 1350485525682

        lastModified: 1232549163000

        mbeans:

       

       

      I thought maybe the version of jboss-remoting that shipped with 4.2.3 was the problem, so I tried manually copying in the jar from jboss remoting 2.2.2.SP11 (which was the closest one I could find, to the 2.2.2.SP12 mentioned on that page), but still got the same error.

       

      Anybody have any thoughts on what is causing this and how to fix it?

       

       

      Thanks in advance!