0 Replies Latest reply on Oct 17, 2012 1:14 PM by Shad Stafford

    Does seam 2.3 require hibernate 4?

    Shad Stafford Newbie

      I haven't found any mention of Seam 2.3 requiring Hibernate 4, but it looks to me like it does. Can anyone confirm that?

       

      Chapter 4 of the docs on migrating from Seam 2.2 to Seam 2.3 doesn't say anything about upgrading hibernate. However, org.jboss.seam.persistence.HibernateSessionInvocationHandler imports org.hibernate.engine.spi.SessionImplementor which I believe only exists in the Hibernate 4 packages. Perhaps I am missing something though, any help would be appreciated.

       

      Thanks

       

      -Shad