2 Replies Latest reply on Oct 19, 2012 10:45 AM by Manish Devraj

    jboss-as-maven-plugin can't deploy to domain mode clustered Jboss AS 7?

    Manish Devraj Newbie

      I am having issue while deploying WAR to my cluster setup which is in domain mode. I am not trying remote deployment, the maven and JBOSS both are running on same machine. As few suggested I have also tried to not use native port for domain mode. Doing following setup in domain.xml

      <subsystem xmlns="urn:jboss:domain:jmx:1.1">
         
      <show-model value="true"/>
         
      <remoting-connector  use-management-endpoint="false" />
      </subsystem>

      By default the JBoss remoting is on 9999 and 4447. I am running single node cluster which adds another remoting port with offset 100 as 4547. I have tried all of these port 4447/4547 goes in infinity without error. While 9999 just drops out without any error.

      My maven configuration is as following

      <domain>
         
      <server-groups>
             
      <server-group>ha-server-group</server-group>
         
      </server-groups>
      <profiles>
         
      <profile>ha</profile>
      </profiles>
      </domain>
      <hostname>127.0.0.1</hostname>
      <port>4547</port>

      Strange part is that maven is able to deploy .jar file using same configuration, but problem arises when I am trying to deploy .war.

      Maven console output is as follows, where for .war it specifies what port it is connecting to when I didn't specify any host port configuration.

      [INFO] --- jboss-as-maven-plugin:7.1.1.Final:deploy (default-cli) @ ABC ---
      Oct 18, 2012 5:39:17 PM org.xnio.Xnio <clinit>
      INFO
      : XNIO Version 3.0.3.GA
      Oct 18, 2012 5:39:17 PM org.xnio.nio.NioXnio <clinit>
      INFO
      : XNIO NIO Implementation Version 3.0.3.GA
      Oct 18, 2012 5:39:17 PM org.jboss.remoting3.EndpointImpl <clinit>
      INFO
      : JBoss Remoting version 3.2.3.GA
      ----------------------------------------------------------------------------------------
      [INFO] --- jboss-as-maven-plugin:7.1.0.Final:deploy (default-cli) @ XYZ ---
      [INFO] Executing goal deploy on server localhost (127.0.0.1) port 9999.
      Oct 18, 2012 5:39:29 PM org.xnio.Xnio <clinit>
      INFO
      : XNIO Version 3.0.3.GA
      Oct 18, 2012 5:39:29 PM org.xnio.nio.NioXnio <clinit>
      INFO
      : XNIO NIO Implementation Version 3.0.3.GA
      Oct 18, 2012 5:39:29 PM org.jboss.remoting3.EndpointImpl <clinit>
      INFO
      : JBoss Remoting version 3.2.2.GA

      I can deploy using CLI but I am looking for maven based solution.