0 Replies Latest reply on May 22, 2002 1:51 PM by Scott

    catalina/hypersonic bugginess

    Scott Newbie

      I'm getting some errors from the web container and database that ship with jboss. First the, catalina error:

      ClassNotFoundException while loading persisted sessions: java.Lang.ClassNotFoundException: .beans.manager

      the is the name of my application. The class file is there in the application jar, with this directory structure: appname.jar/appname/beans/manager.class. Maybe its supposed to be appname.jar/beans/manager.class? But if thats the case, how come every other part of the app can find the class file just fine? It didn't start giving me this error until recently, and it was working before. It gives the same error when jboss destroys the app, but instead it says "error in unloading session from persistant storage."


      The database error is a little wierder. I set up an entity bean using CMP with about 10 container managed fields. Later, i decided i needed to add one more field, called "points". I put the variable in the bean, wrote the setters and getters, and declared it as a cmp field in ejb-jar.xml, but when i try to create an instance of this bean, jboss throws an SQL exception telling me that there is no column by the name "POINTS".


      javax.transaction.TransactionRollbackException:
      Could not create entity: java.sql.SQLException: Column not found: POINTS in statement [INSERT INTO ( <all of the fields are here> ) VALUES ( <values for fields are listed here> )]


      The thing that gets me is that the exception message lists "points" as one of the fields. I tried putting points in all caps in all of the code, as if that might do something. it didn't. Either i didn't add the new the field to some file that i was supposed to, or the database is just quirky. I'm inclined to think that the database is fine and i'm screwing up, but if not, its ok cause i'm we're using a different database for our production server. Still, i'd like to know what the deal is. Maybe the table is setup in the database and I need to get it out and re create it? How do I do that with hypersonic?

      Sorry about the long post.