0 Replies Latest reply on Oct 22, 2012 8:43 PM by Brenden Towey

    New missing/unsatisfied dependencies?

    Brenden Towey Newbie

      I keep seeing this error "New missing/unsatisfied dependencies".  I think there must be something basic I'm missing.

       

      00:28:20,057 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014775:    New missing/unsatisfied dependencies:

            service jboss.jdbc-driver.mysql (missing) dependents: [service jboss.data-source.java:/comp/env/jdbc/simpletth]

       

      In my war file, I have datasource:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <persistence version="2.0" xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_2_0.xsd">

       

        <persistence-unit name="SimpleTthPU" transaction-type="JTA">

          <provider>org.hibernate.ejb.HibernatePersistence</provider>

          <jta-data-source>java:/comp/env/jdbc/simpletth</jta-data-source>

          <exclude-unlisted-classes>false</exclude-unlisted-classes>

          <properties>

            <property name="hibernate.hbm2ddl.auto" value="update"/>

          </properties>

        </persistence-unit>

      </persistence>

       

       

      In my JBoss AS 71.1 Final standalone.xml file, I have the following:

       

                  <datasources>

                      <datasource jndi-name="java:/comp/env/jdbc/simpletth" pool-name="simpletth" enabled="true" use-java-context="true">

                          <connection-url>jdbc:mysql://localhost/simpletth</connection-url>

                          <driver>mysql</driver>

                          <transaction-isolation>TRANSACTION_READ_COMMITTED</transaction-isolation>

                          <security>

                              <user-name>aaaa</user-name>

                              <password>xxxx</password>

                          </security>

                      </datasource>

       

      I think perhaps I don't understand well enough how these get bound.  Can anyone explain why I'm seeing the above error message?