0 Replies Latest reply on Oct 25, 2012 2:01 PM by thinksteep thinksteep

    Jboss 7.1.1Final ---Could not register a EJB receiver

    thinksteep thinksteep Novice

      Hi,

       

      I am trying to make EJB invocation from remote (Standalone java) client using follwoing tutorial

       

      https://docs.jboss.org/author/display/AS71/EJB+invocations+from+a+remote+client+using+JNDI

       

       

      Somehow I am unable to succeed. Client still trying to register on localhost instead of remote IP. I was expecting connection to should be remote://myIP:4447. This is what I have confgured as provider url.

       

      Follwoing is the exception.

       

      13:21:38,084 INFO  JBoss EJB Client version 1.0.5.Final

      13:21:43,118 WARN  Could not register a EJB receiver for connection to remote://

      localhost:4447

      java.lang.RuntimeException: Operation failed with status WAITING

              at org.jboss.ejb.client.remoting.IoFutureHelper.get(IoFutureHelper.java:

      93)

              at org.jboss.ejb.client.remoting.ConfigBasedEJBClientContextSelector.set

      upEJBReceivers(ConfigBasedEJBClientContextSelector.java:121)

              at org.jboss.ejb.client.remoting.ConfigBasedEJBClientContextSelector.<in

      it>(ConfigBasedEJBClientContextSelector.java:78)

              at org.jboss.ejb.client.EJBClientContext.<clinit>(EJBClientContext.java:

      77)

              at org.jboss.ejb.client.EJBInvocationHandler.doInvoke(EJBInvocationHandl

      er.java:120)

              at org.jboss.ejb.client.EJBInvocationHandler.invoke(EJBInvocationHandler

      .java:104)

       

      I have jboss-ejb-client.properties defined like below:

       

      remote.connections=default

      remote.connection.default.host=myIP

      remote.connection.default.port = 4447

      remote.connection.default.connect.options.org.xnio.Options.SASL_POLICY_NOANONYMOUS=false

       

      Any help would be appreciated.

       

      Thank you,