9 Replies Latest reply on Oct 30, 2012 12:25 PM by Steven Boscarine

    Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?

    Steven Boscarine Apprentice

      Hello All,

      I have a legacy app that works in EAP 4.3 that I am porting to EAP6. I get the error below, which tells me nothing of why the app is failing. 

       

      I believe it is failing to load the Spring context, but I have no clue why or what piece of the app is failing. 

       

      Are there any tricks, either in Spring or JBoss AS/EAP, to figure out what is causing the error?  Can I tune the logging for deployment?

       

      Thanks in advance!

       

       

      The error is:

      11:59:58,103 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC000001: Failed to start service jboss.web.deployment.default-host./cmdbcanary: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./cmdbcanary: JBAS018040: Failed to start context
              at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:95)
              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_03]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_03]
              at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_03]
      
      11:59:58,116 INFO  [org.jboss.as.server] (management-handler-thread - 72) JBAS018562: Redeployed "cmdbcanary.war"
      11:59:58,116 INFO  [org.jboss.as.server] (management-handler-thread - 72) JBAS018565: Replaced deployment "cmdbcanary.war" with deployment "cmdbcanary
      .war"
      11:59:58,116 INFO  [org.jboss.as.controller] (management-handler-thread - 72) JBAS014774: Service status report
      JBAS014777:   Services which failed to start:      service jboss.web.deployment.default-host./cmdbcanary: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./cmdbcanary: JBAS018040: Failed to start context
      
      11:59:58,121 INFO  [org.jboss.as.repository] (management-handler-thread - 72) JBAS014901: Content removed from location C:\tools\jboss-eap-6.0\bin\..\standalone\data\content\9a\ef0cfde26d3e5cf18c7567c8a44efb510b6d37\content
      
        • 1. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
          Stephen Coy Master

          Please

          • Confirm that you are not using Spring Framework versions between 2.5 and 3.0.1. These are known to be incompatible with all versions of JBoss from 5.0 or so and newer;
          • Attach the complete server log to this discussion
          • 2. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
            Tomaz Cerar Master

            Hi,

             

            can you post full server.log and output of jar tf <name of your deployment archive>

             

            also there are some known issues with deploying spring apps on 7.1.1 could you try with 7.2 nightly build or build yourself 7.1.3.Final?

             

             

            --

            tomaz

            • 3. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
              Steven Boscarine Apprentice

              Thank you for the quick responses.  I attached the updated logs.  We're using Spring 3.0.6. 

               

              Regarding containers, we need to deploy this application to EAP6, whatever the latest point release is whenever the port is complete.  I suspect there's a problem with my Spring Context in that a dependency is missing or jars mismatch.  One thing about the application is that it bundled Hibernate and CXF for 4.3 and now many of those services are provided by the container, so that may be a source of conflict.  I just need to see some stacktrace that gives me a hint as to why JBoss won't startup.

               

              If I can't find another lead, I can try it on a newer container.  I just can't deliver it to the customer.

               

              Thanks!

              Steven

              • 4. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
                Tomaz Cerar Master

                Hi,

                 

                7.1.2 / EAP6.0.0 has some of that problems fixed so you should be good here.

                 

                can you post also output(structure) of your application

                you get that by

                 

                jar tf cmdbcanary.war

                 

                or

                 

                jar tf slcorecanary.war

                 

                tnx,

                tomaz

                1 of 1 people found this helpful
                • 5. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
                  Steven Boscarine Apprentice

                  Hello Tomaz,

                  Thanks for the quick response.  Here's the output.  The *canary name refers to "canary in a coal mine" it's a subset of the actual application, simplified from the first war.

                  META-INF/
                  META-INF/MANIFEST.MF
                  WEB-INF/
                  WEB-INF/classes/
                  WEB-INF/classes/com/
                  WEB-INF/classes/com/mydomain/
                  WEB-INF/classes/config/
                  WEB-INF/classes/config/spring/
                  WEB-INF/lib/
                  WEB-INF/templates/
                  index.html
                  index2.jsp
                  WEB-INF/beans.xml
                  WEB-INF/classes/com/mydomain/App.class
                  WEB-INF/classes/config/spring/applicationContext.xml
                  WEB-INF/classes/config/spring/ws-beans.xml
                  WEB-INF/classes/config/spring/ws-environment.xml
                  WEB-INF/lib/acs-protocol-2.0.0.0-20120621.171242-43.jar
                  WEB-INF/lib/activation-1.1.jar
                  WEB-INF/lib/activeio-core-3.1.0.jar
                  WEB-INF/lib/activemq-camel-5.2.0.jar
                  WEB-INF/lib/activemq-core-5.2.0.jar
                  WEB-INF/lib/activemq-pool-5.2.0.jar
                  WEB-INF/lib/antlr-2.7.7.jar
                  WEB-INF/lib/antlr-runtime-3.4.jar
                  WEB-INF/lib/aopalliance-1.0.jar
                  WEB-INF/lib/asm-3.2.jar
                  WEB-INF/lib/asmp-6.1.4.0.jar
                  WEB-INF/lib/aspectjrt-1.5.3.jar
                  WEB-INF/lib/aspectjweaver-1.5.3.jar
                  WEB-INF/lib/awp-6.1.4.0.jar
                  WEB-INF/lib/mydomain-licensing-1.0.6.jar
                  WEB-INF/lib/mydomain-module-common-0.0.41.jar
                  WEB-INF/lib/mydomain-protocol-common-6.1.4.0.jar
                  WEB-INF/lib/axis-1.4.jar
                  WEB-INF/lib/axis-jaxrpc-1.4.jar
                  WEB-INF/lib/backport-util-concurrent-2.1.jar
                  WEB-INF/lib/bcprov-jdk15-140.jar
                  WEB-INF/lib/c3p0-0.9.1.jar
                  WEB-INF/lib/camel-core-2.8.1.jar
                  WEB-INF/lib/camel-jms-2.8.1.jar
                  WEB-INF/lib/camel-spring-2.8.1.jar
                  WEB-INF/lib/castor-0.9.3.19.jar
                  WEB-INF/lib/cglib-nodep-2.1_3.jar
                  WEB-INF/lib/cmdb-2.0.58.jar
                  WEB-INF/lib/cognos-axis-8.4.jar
                  WEB-INF/lib/cognos-client-8.4.jar
                  WEB-INF/lib/commons-beanutils-1.6.1.jar
                  WEB-INF/lib/commons-codec-1.4.jar
                  WEB-INF/lib/commons-collections-3.0.jar
                  WEB-INF/lib/commons-configuration-1.6.jar
                  WEB-INF/lib/commons-digester-1.8.jar
                  WEB-INF/lib/commons-discovery-0.2.jar
                  WEB-INF/lib/commons-el-1.0.jar
                  WEB-INF/lib/commons-fileupload-1.2.1.jar
                  WEB-INF/lib/commons-httpclient-3.0.1.jar
                  WEB-INF/lib/commons-io-1.4.jar
                  WEB-INF/lib/commons-jxpath-1.3.jar
                  WEB-INF/lib/commons-lang-2.6.jar
                  WEB-INF/lib/commons-logging-1.0.jar
                  WEB-INF/lib/commons-logging-api-1.1.jar
                  WEB-INF/lib/commons-management-1.0.jar
                  WEB-INF/lib/commons-math-2.2.jar
                  WEB-INF/lib/commons-net-2.0.jar
                  WEB-INF/lib/commons-pool-1.4.jar
                  WEB-INF/lib/commons-validator-1.0.2.jar
                  WEB-INF/lib/concurrent-1.0.jar
                  WEB-INF/lib/cxf-api-2.5.1.jar
                  WEB-INF/lib/cxf-common-utilities-2.5.1.jar
                  WEB-INF/lib/cxf-rt-bindings-soap-2.5.1.jar
                  WEB-INF/lib/cxf-rt-bindings-xml-2.5.1.jar
                  WEB-INF/lib/cxf-rt-core-2.5.1.jar
                  WEB-INF/lib/cxf-rt-databinding-jaxb-2.5.1.jar
                  WEB-INF/lib/cxf-rt-frontend-jaxws-2.5.1.jar
                  WEB-INF/lib/cxf-rt-frontend-simple-2.5.1.jar
                  WEB-INF/lib/cxf-rt-transports-common-2.5.1.jar
                  WEB-INF/lib/cxf-rt-transports-http-2.5.1.jar
                  WEB-INF/lib/cxf-rt-ws-addr-2.5.1.jar
                  WEB-INF/lib/cxf-rt-ws-security-2.5.1.jar
                  WEB-INF/lib/cxf-tools-common-2.5.1.jar
                  WEB-INF/lib/cxf-tools-validator-2.5.1.jar
                  WEB-INF/lib/cxf-tools-wsdlto-core-2.5.1.jar
                  WEB-INF/lib/cxf-tools-wsdlto-databinding-jaxb-2.5.1.jar
                  WEB-INF/lib/cxf-tools-wsdlto-frontend-jaxws-2.5.1.jar
                  WEB-INF/lib/data-accumulator-0.1.0.jar
                  WEB-INF/lib/dom4j-1.6.1.jar
                  WEB-INF/lib/ehcache-core-2.0.0.jar
                  WEB-INF/lib/ehcache-jgroupsreplication-1.3.jar
                  WEB-INF/lib/ehcache-jmsreplication-0.4.jar
                  WEB-INF/lib/ehcache-terracotta-2.0.0.jar
                  WEB-INF/lib/ezmorph-1.0.6.jar
                  WEB-INF/lib/fileupload-1.0.12.jar
                  WEB-INF/lib/fileupload-api-1.0.3.jar
                  WEB-INF/lib/geoapi-2.2-M1.jar
                  WEB-INF/lib/geronimo-javamail_1.4_spec-1.7.1.jar
                  WEB-INF/lib/geronimo-jms_1.1_spec-1.1.1.jar
                  WEB-INF/lib/geronimo-jta_1.0.1B_spec-1.0.1.jar
                  WEB-INF/lib/groovy-all-1.8.2.jar
                  WEB-INF/lib/gt-api-2.5.2.jar
                  WEB-INF/lib/gt-epsg-wkt-2.5.2.jar
                  WEB-INF/lib/gt-metadata-2.5.2.jar
                  WEB-INF/lib/gt-referencing-2.5.2.jar
                  WEB-INF/lib/harmony-asn1-6.0.1.jar
                  WEB-INF/lib/hibernate-c3p0-4.1.0.Final.jar
                  WEB-INF/lib/hibernate-commons-annotations-4.0.1.Final.jar
                  WEB-INF/lib/hibernate-core-4.1.0.Final.jar
                  WEB-INF/lib/hibernate-ehcache-4.1.0.Final.jar
                  WEB-INF/lib/hibernate-jbosscache-3.3.2.GA.jar
                  WEB-INF/lib/hibernate-jbosscache2-3.3.2.GA.jar
                  WEB-INF/lib/hibernate-jmx-3.3.2.GA.jar
                  WEB-INF/lib/hibernate-oscache-3.3.2.GA.jar
                  WEB-INF/lib/hibernate-proxool-4.1.0.Final.jar
                  WEB-INF/lib/hibernate-spatial-1.0-M2-mydomain-1.0.jar
                  WEB-INF/lib/hibernate-spatial-oracle-1.0-M2-mydomain-1.0.jar
                  WEB-INF/lib/hibernate-swarmcache-3.3.2.GA.jar
                  WEB-INF/lib/http-builder-0.5.0-RC2.jar
                  WEB-INF/lib/httpclient-4.0.1.jar
                  WEB-INF/lib/httpcore-4.0.1.jar
                  WEB-INF/lib/jai-core-1.1.3.jar
                  WEB-INF/lib/javassist-3.12.0.GA.jar
                  WEB-INF/lib/javassist-3.15.0-GA.jar
                  WEB-INF/lib/javatar-2.5.jar
                  WEB-INF/lib/jaxb-impl-2.2.5.jar
                  WEB-INF/lib/jaxb-xjc-2.2.5.jar
                  WEB-INF/lib/jaxrpc-api-1.1.jar
                  WEB-INF/lib/jboss-cache-1.4.1.GA.jar
                  WEB-INF/lib/jboss-common-4.0.2.jar
                  WEB-INF/lib/jboss-common-core-2.2.10.GA.jar
                  WEB-INF/lib/jboss-common-jdbc-wrapper-4.3.0.GA_CP06.jar
                  WEB-INF/lib/jboss-j2se-200504122039.jar
                  WEB-INF/lib/jboss-logging-3.1.0.CR2.jar
                  WEB-INF/lib/jboss-logging-spi-2.0.5.GA.jar
                  WEB-INF/lib/jboss-minimal-4.0.2.jar
                  WEB-INF/lib/jboss-system-4.0.2.jar
                  WEB-INF/lib/jboss-transaction-api_1.1_spec-1.0.0.Final.jar
                  WEB-INF/lib/jbossall-client-3.2.3.jar
                  WEB-INF/lib/jbosscache-core-3.1.0.GA.jar
                  WEB-INF/lib/jcert-1.0.jar
                  WEB-INF/lib/jdbc-stdext-2.0.jar
                  WEB-INF/lib/jdom-0.7.jar
                  WEB-INF/lib/jep-3.3.0.jar
                  WEB-INF/lib/jgroups-2.6.8.GA.jar
                  WEB-INF/lib/jms-1.1.jar
                  WEB-INF/lib/jnet-1.0.jar
                  WEB-INF/lib/joda-time-1.6.2.jar
                  WEB-INF/lib/json-lib-2.3-jdk15.jar
                  WEB-INF/lib/jsr-275-1.0-beta-2.jar
                  WEB-INF/lib/jsse-1.0.jar
                  WEB-INF/lib/jstl-1.1.2.jar
                  WEB-INF/lib/jta-1.1.jar
                  WEB-INF/lib/jts-1.10.jar
                  WEB-INF/lib/junit-4.4.jar
                  WEB-INF/lib/ldapcontr-1.0.jar
                  WEB-INF/lib/log4j-1.2.15.jar
                  WEB-INF/lib/mail-1.4.4.jar
                  WEB-INF/lib/mina-core-2.0.4.jar
                  WEB-INF/lib/neethi-3.0.1.jar
                  WEB-INF/lib/nekohtml-1.9.9.jar
                  WEB-INF/lib/ojdbc6-11.2.0.2.0.jar
                  WEB-INF/lib/opensaml-2.5.1-1.jar
                  WEB-INF/lib/openws-1.4.2-1.jar
                  WEB-INF/lib/oracle.integration.proxy-1.0.jar
                  WEB-INF/lib/oro-2.0.6.jar
                  WEB-INF/lib/oscache-2.1.jar
                  WEB-INF/lib/placeholder-6.6.0.0-SNAPSHOT.jar
                  WEB-INF/lib/proxool-0.8.3.jar
                  WEB-INF/lib/qdox-1.12.jar
                  WEB-INF/lib/quartz-1.6.5.jar
                  WEB-INF/lib/scribe-1.3.0.jar
                  WEB-INF/lib/seam-spring-core-3.1.0.Final.jar
                  WEB-INF/lib/serializer-j_2.7.0.jar
                  WEB-INF/lib/shiftone-arbor-1.0.jar
                  WEB-INF/lib/simple-1.0.jar
                  WEB-INF/lib/sl-common-api-6.6-SNAPSHOT.jar
                  WEB-INF/lib/sl-core-6.6-SNAPSHOT.jar
                  WEB-INF/lib/slf4j-api-1.5.6.jar
                  WEB-INF/lib/slf4j-log4j12-1.5.6.jar
                  WEB-INF/lib/smppapi-1.0.jar
                  WEB-INF/lib/spring-aop-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-asm-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-beans-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-context-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-context-support-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-core-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-expression-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-jdbc-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-jms-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-orm-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-tx-3.0.6.RELEASE.jar
                  WEB-INF/lib/spring-web-3.0.6.RELEASE.jar
                  WEB-INF/lib/sshd-core-svn-rev-1167185.jar
                  WEB-INF/lib/standard-1.1.2.jar
                  WEB-INF/lib/stax2-api-3.1.1.jar
                  WEB-INF/lib/stringtemplate-3.2.1.jar
                  WEB-INF/lib/struts-1.1.jar
                  WEB-INF/lib/struts-legacy-1.1.jar
                  WEB-INF/lib/sunjce_provider-1.0.jar
                  WEB-INF/lib/swarmcache-1.0RC2.jar
                  WEB-INF/lib/vecmath-1.3.1.jar
                  WEB-INF/lib/velocity-1.7.jar
                  WEB-INF/lib/webdavlib-2.0.jar
                  WEB-INF/lib/woodstox-core-asl-4.1.1.jar
                  WEB-INF/lib/wsdl4j-1.6.2.jar
                  WEB-INF/lib/wss4j-1.6.4.jar
                  WEB-INF/lib/xalan-1.0.jar
                  WEB-INF/lib/xbean-spring-3.4.jar
                  WEB-INF/lib/xercesImpl-2.9.0.jar
                  WEB-INF/lib/xml-apis-1.3.04.jar
                  WEB-INF/lib/xml-resolver-1.2.jar
                  WEB-INF/lib/xmlschema-core-2.0.1.jar
                  WEB-INF/lib/xmlsec-1.4.6.jar
                  WEB-INF/lib/xmltooling-1.3.2-1.jar
                  WEB-INF/lib/xpp3_min-1.1.4c.jar
                  WEB-INF/lib/xsltc-1.0.jar
                  WEB-INF/lib/xstream-1.3.1.jar
                  WEB-INF/templates/default.xhtml
                  WEB-INF/web.xml
                  META-INF/maven/
                  META-INF/maven/com.mydomain/
                  META-INF/maven/com.mydomain/slcorecanary/
                  META-INF/maven/com.mydomain/slcorecanary/pom.xml
                  META-INF/maven/com.mydomain/slcorecanary/pom.properties
                  
                  • 6. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
                    Steven Boscarine Apprentice

                    Support answered.  To others reading,

                    standalone.sh -Dorg.jboss.as.logging.per-deployment=false
                    

                    was what I needed to show the Spring errors.  Not sure what this parameter is meant to do or why it's configured this way by default.  I wish I could find info explaining more about the parameter since it appears to be cricital to getting an application working on this product.

                    • 7. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
                      Tomaz Cerar Master

                      Hi,

                       

                      there is bunch of jar files in your lib directory that are not needed and should be removed.

                      line by line:

                       

                      WEB-INF/lib/acs-protocol-2.0.0.0-20120621.171242-43.jar
                      WEB-INF/lib/activation-1.1.jar <-- this is part of JDK & APP server, no need to include it
                      WEB-INF/lib/activeio-core-3.1.0.jar
                      WEB-INF/lib/activemq-camel-5.2.0.jar
                      WEB-INF/lib/activemq-core-5.2.0.jar
                      WEB-INF/lib/activemq-pool-5.2.0.jar
                      WEB-INF/lib/antlr-2.7.7.jar <-- is dependency of hibernate which is part of app server
                      WEB-INF/lib/antlr-runtime-3.4.jar <-- same as above
                      WEB-INF/lib/aopalliance-1.0.jar <-- same as above
                      WEB-INF/lib/asm-3.2.jar <-- same as above
                      WEB-INF/lib/asmp-6.1.4.0.jar
                      WEB-INF/lib/aspectjrt-1.5.3.jar <-- this is probably leftover
                      WEB-INF/lib/aspectjweaver-1.5.3.jar <-- lefover?
                      WEB-INF/lib/awp-6.1.4.0.jar
                      WEB-INF/lib/mydomain-licensing-1.0.6.jar
                      WEB-INF/lib/mydomain-module-common-0.0.41.jar
                      WEB-INF/lib/mydomain-protocol-common-6.1.4.0.jar
                      WEB-INF/lib/axis-1.4.jar <-- your app uses axis?, if not remove
                      WEB-INF/lib/axis-jaxrpc-1.4.jar <-- axis, if not in use, remove
                      WEB-INF/lib/backport-util-concurrent-2.1.jar <-- not needed, this is part of java6+,
                      WEB-INF/lib/bcprov-jdk15-140.jar <-- should probably be upgrade of jdk16 version
                      WEB-INF/lib/c3p0-0.9.1.jar <-- use internal datasource pooling instead of c3po, remove
                      WEB-INF/lib/camel-core-2.8.1.jar
                      WEB-INF/lib/camel-jms-2.8.1.jar
                      WEB-INF/lib/camel-spring-2.8.1.jar
                      WEB-INF/lib/castor-0.9.3.19.jar
                      WEB-INF/lib/cglib-nodep-2.1_3.jar <-- another hibernate dependancy, remove
                      WEB-INF/lib/cmdb-2.0.58.jar
                      WEB-INF/lib/cognos-axis-8.4.jar
                      WEB-INF/lib/cognos-client-8.4.jar
                      WEB-INF/lib/commons-beanutils-1.6.1.jar
                      WEB-INF/lib/commons-codec-1.4.jar
                      WEB-INF/lib/commons-collections-3.0.jar
                      WEB-INF/lib/commons-configuration-1.6.jar
                      WEB-INF/lib/commons-digester-1.8.jar
                      WEB-INF/lib/commons-discovery-0.2.jar
                      WEB-INF/lib/commons-el-1.0.jar <-- probably not neeed, remove
                      WEB-INF/lib/commons-fileupload-1.2.1.jar
                      WEB-INF/lib/commons-httpclient-3.0.1.jar
                      WEB-INF/lib/commons-io-1.4.jar
                      WEB-INF/lib/commons-jxpath-1.3.jar
                      WEB-INF/lib/commons-lang-2.6.jar <-- this is part of as, try to remove it if possible
                      WEB-INF/lib/commons-logging-1.0.jar <-- remove
                      WEB-INF/lib/commons-logging-api-1.1.jar <-- remove
                      WEB-INF/lib/commons-management-1.0.jar
                      WEB-INF/lib/commons-math-2.2.jar
                      WEB-INF/lib/commons-net-2.0.jar
                      WEB-INF/lib/commons-pool-1.4.jar
                      WEB-INF/lib/commons-validator-1.0.2.jar
                      WEB-INF/lib/concurrent-1.0.jar <-- remove
                      WEB-INF/lib/cxf-api-2.5.1.jar <-- cxf is part of AS7 and no need to include it in you app, if not imported by default you could add dependancy to org.apache.cxf module
                      WEB-INF/lib/cxf-common-utilities-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-bindings-soap-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-bindings-xml-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-core-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-databinding-jaxb-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-frontend-jaxws-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-frontend-simple-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-transports-common-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-transports-http-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-ws-addr-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-rt-ws-security-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-tools-common-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-tools-validator-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-tools-wsdlto-core-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-tools-wsdlto-databinding-jaxb-2.5.1.jar <-- same as above
                      WEB-INF/lib/cxf-tools-wsdlto-frontend-jaxws-2.5.1.jar <-- same as above
                      WEB-INF/lib/data-accumulator-0.1.0.jar
                      WEB-INF/lib/dom4j-1.6.1.jar <-- remove
                      WEB-INF/lib/ehcache-core-2.0.0.jar <-- do you use ehcache in you app?
                      WEB-INF/lib/ehcache-jgroupsreplication-1.3.jar <-- you use ehchache with replication? if not remove
                      WEB-INF/lib/ehcache-jmsreplication-0.4.jar <-- same as above
                      WEB-INF/lib/ehcache-terracotta-2.0.0.jar <-- same as above
                      WEB-INF/lib/ezmorph-1.0.6.jar
                      WEB-INF/lib/fileupload-1.0.12.jar
                      WEB-INF/lib/fileupload-api-1.0.3.jar
                      WEB-INF/lib/geoapi-2.2-M1.jar
                      WEB-INF/lib/geronimo-javamail_1.4_spec-1.7.1.jar <-- remove this is part of EE spec and should not be included in user's app
                      WEB-INF/lib/geronimo-jms_1.1_spec-1.1.1.jar  <-- same as above
                      WEB-INF/lib/geronimo-jta_1.0.1B_spec-1.0.1.jar <-- same as above
                      WEB-INF/lib/groovy-all-1.8.2.jar
                      WEB-INF/lib/gt-api-2.5.2.jar
                      WEB-INF/lib/gt-epsg-wkt-2.5.2.jar
                      WEB-INF/lib/gt-metadata-2.5.2.jar
                      WEB-INF/lib/gt-referencing-2.5.2.jar
                      WEB-INF/lib/harmony-asn1-6.0.1.jar
                      WEB-INF/lib/hibernate-c3p0-4.1.0.Final.jar <-- hiberenate is part of AS no need to bundle your own
                      WEB-INF/lib/hibernate-commons-annotations-4.0.1.Final.jar <-- same as above
                      WEB-INF/lib/hibernate-core-4.1.0.Final.jar <-- same as above
                      WEB-INF/lib/hibernate-ehcache-4.1.0.Final.jar <-- do you use ehcache for caching?
                      WEB-INF/lib/hibernate-jbosscache-3.3.2.GA.jar <-- or do you use jbosscache?
                      WEB-INF/lib/hibernate-jbosscache2-3.3.2.GA.jar <-- or do you use jbosscache2?
                      WEB-INF/lib/hibernate-jmx-3.3.2.GA.jar <-- remove
                      WEB-INF/lib/hibernate-oscache-3.3.2.GA.jar <-- remove
                      WEB-INF/lib/hibernate-proxool-4.1.0.Final.jar <-- remove
                      WEB-INF/lib/hibernate-spatial-1.0-M2-mydomain-1.0.jar
                      WEB-INF/lib/hibernate-spatial-oracle-1.0-M2-mydomain-1.0.jar
                      WEB-INF/lib/hibernate-swarmcache-3.3.2.GA.jar <-- do you use alos swarmcache in you app?
                      WEB-INF/lib/http-builder-0.5.0-RC2.jar
                      WEB-INF/lib/httpclient-4.0.1.jar <-- could be remove, and included via dependancy form AS
                      WEB-INF/lib/httpcore-4.0.1.jar <-- same as above
                      WEB-INF/lib/jai-core-1.1.3.jar
                      WEB-INF/lib/javassist-3.12.0.GA.jar <-- remove javaasist
                      WEB-INF/lib/javassist-3.15.0-GA.jar <-- especialy two versions of it
                      WEB-INF/lib/javatar-2.5.jar
                      WEB-INF/lib/jaxb-impl-2.2.5.jar <-- this is part of JDK/app server, remove
                      WEB-INF/lib/jaxb-xjc-2.2.5.jar  <-- same as above
                      WEB-INF/lib/jaxrpc-api-1.1.jar <-- same as above
                      WEB-INF/lib/jboss-cache-1.4.1.GA.jar <-- this is 6th cache impl you have in you app?
                      WEB-INF/lib/jboss-common-4.0.2.jar <-- why do you bundle core libs from jboss 4?, remove
                      WEB-INF/lib/jboss-common-core-2.2.10.GA.jar <-- same as above
                      WEB-INF/lib/jboss-common-jdbc-wrapper-4.3.0.GA_CP06.jar <-- same as above
                      WEB-INF/lib/jboss-j2se-200504122039.jar <-- same as above
                      WEB-INF/lib/jboss-logging-3.1.0.CR2.jar <-- same as above
                      WEB-INF/lib/jboss-logging-spi-2.0.5.GA.jar <-- same as above
                      WEB-INF/lib/jboss-minimal-4.0.2.jar <-- same as above
                      WEB-INF/lib/jboss-system-4.0.2.jar <-- same as above
                      WEB-INF/lib/jboss-transaction-api_1.1_spec-1.0.0.Final.jar <-- part of EE spec / app server, remove
                      WEB-INF/lib/jbossall-client-3.2.3.jar <-- why do you need jbossclient 3.2.3? do you connect to jboss 3.2.3 from your app?
                      WEB-INF/lib/jbosscache-core-3.1.0.GA.jar <-- 7th cache impl?
                      WEB-INF/lib/jcert-1.0.jar
                      WEB-INF/lib/jdbc-stdext-2.0.jar
                      WEB-INF/lib/jdom-0.7.jar
                      WEB-INF/lib/jep-3.3.0.jar
                      WEB-INF/lib/jgroups-2.6.8.GA.jar <-- AS7 comes with jgroups already, no need to bundle it
                      WEB-INF/lib/jms-1.1.jar <-- part of EE spec / app server
                      WEB-INF/lib/jnet-1.0.jar
                      WEB-INF/lib/joda-time-1.6.2.jar
                      WEB-INF/lib/json-lib-2.3-jdk15.jar <-- probably time to update this?
                      WEB-INF/lib/jsr-275-1.0-beta-2.jar <-- this should probably be updated?
                      WEB-INF/lib/jsse-1.0.jar <-- tomcats ssl lib? probably some leftover, remove it
                      WEB-INF/lib/jstl-1.1.2.jar  <-- part of EE spec/ app server, remove it
                      WEB-INF/lib/jta-1.1.jar <-- part of EE spec / app server, remove it
                      WEB-INF/lib/jts-1.10.jar <-- part of app server, remove it
                      WEB-INF/lib/junit-4.4.jar <-- junit on server? probably mistake
                      WEB-INF/lib/ldapcontr-1.0.jar
                      WEB-INF/lib/log4j-1.2.15.jar <-- you dont need to include that, app server does that for you, but you can leave it..
                      WEB-INF/lib/mail-1.4.4.jar <-- part of EE spec / app server, remove it
                      WEB-INF/lib/mina-core-2.0.4.jar
                      WEB-INF/lib/neethi-3.0.1.jar
                      WEB-INF/lib/nekohtml-1.9.9.jar
                      WEB-INF/lib/ojdbc6-11.2.0.2.0.jar <-- jdbc driver does not belong into app itself..
                      WEB-INF/lib/opensaml-2.5.1-1.jar
                      WEB-INF/lib/openws-1.4.2-1.jar
                      WEB-INF/lib/oracle.integration.proxy-1.0.jar
                      WEB-INF/lib/oro-2.0.6.jar
                      WEB-INF/lib/oscache-2.1.jar <-- another cache impl?
                      WEB-INF/lib/placeholder-6.6.0.0-SNAPSHOT.jar
                      WEB-INF/lib/proxool-0.8.3.jar
                      WEB-INF/lib/qdox-1.12.jar
                      WEB-INF/lib/quartz-1.6.5.jar <-- you need quartz directly or is this some transtive dependancy? you could probably remove it
                      WEB-INF/lib/scribe-1.3.0.jar
                      WEB-INF/lib/seam-spring-core-3.1.0.Final.jar
                      WEB-INF/lib/serializer-j_2.7.0.jar <-- xml parser, part of app server, remove
                      WEB-INF/lib/shiftone-arbor-1.0.jar
                      WEB-INF/lib/simple-1.0.jar
                      WEB-INF/lib/sl-common-api-6.6-SNAPSHOT.jar
                      WEB-INF/lib/sl-core-6.6-SNAPSHOT.jar
                      WEB-INF/lib/slf4j-api-1.5.6.jar <-- part of app server, you could remove it
                      WEB-INF/lib/slf4j-log4j12-1.5.6.jar <-- same as above
                      WEB-INF/lib/smppapi-1.0.jar
                      WEB-INF/lib/spring-aop-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-asm-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-beans-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-context-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-context-support-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-core-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-expression-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-jdbc-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-jms-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-orm-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-tx-3.0.6.RELEASE.jar
                      WEB-INF/lib/spring-web-3.0.6.RELEASE.jar
                      WEB-INF/lib/sshd-core-svn-rev-1167185.jar
                      WEB-INF/lib/standard-1.1.2.jar <-- part of EE spec / app server, remove it
                      WEB-INF/lib/stax2-api-3.1.1.jar <-- you could proably remove this
                      WEB-INF/lib/stringtemplate-3.2.1.jar
                      WEB-INF/lib/struts-1.1.jar
                      WEB-INF/lib/struts-legacy-1.1.jar
                      WEB-INF/lib/sunjce_provider-1.0.jar <-- jdk's jce provider in app? probably mistake
                      WEB-INF/lib/swarmcache-1.0RC2.jar <-- another cache??
                      WEB-INF/lib/vecmath-1.3.1.jar
                      WEB-INF/lib/velocity-1.7.jar
                      WEB-INF/lib/webdavlib-2.0.jar
                      WEB-INF/lib/woodstox-core-asl-4.1.1.jar
                      WEB-INF/lib/wsdl4j-1.6.2.jar <-- could proably remove it
                      WEB-INF/lib/wss4j-1.6.4.jar <-- same as above
                      WEB-INF/lib/xalan-1.0.jar <-- should proabably remove it, this is anicient...
                      WEB-INF/lib/xbean-spring-3.4.jar
                      WEB-INF/lib/xercesImpl-2.9.0.jar <-- no need to bundle, remove
                      WEB-INF/lib/xml-apis-1.3.04.jar <-- remove
                      WEB-INF/lib/xml-resolver-1.2.jar <-- remove
                      WEB-INF/lib/xmlschema-core-2.0.1.jar <-- remove
                      WEB-INF/lib/xmlsec-1.4.6.jar <-- probable safe to remove
                      WEB-INF/lib/xmltooling-1.3.2-1.jar
                      WEB-INF/lib/xpp3_min-1.1.4c.jar <-- praobly save to remove
                      WEB-INF/lib/xsltc-1.0.jar
                      WEB-INF/lib/xstream-1.3.1.jar <-- probably save to remove

                       

                      It looks like you have bunch of duplicated and unneeded jar bundled in your app.

                      First thing to remove are all ee spec provided jars as they might give you problems.

                      Hibernate 4 is part of app server so no need to bundle it also all the caches and its dependancies.

                      check what cache provider you are actualy using and keep just that one.

                       

                      also configure datasource directly in app server and don't use jdbc directly, you might need to fix few configruation files.

                       

                      probably you have just few bugs in you maven project, where you should define all dependancies that are part of app server as <scope>provided</scope>

                       

                      i would also recomend you to use

                      mvn dependency:tree

                      to show you from where dependancies are coming into your resulting build.

                       

                      hope this helps

                       

                      --

                      tomaz

                      1 of 1 people found this helpful
                      • 9. Re: Spring App failling in EAP6/AS7.1, works in EAP 4.3 no error...how can I tune logging?  Does AS suppress Spring errors?
                        Steven Boscarine Apprentice

                        Thank you so much Tomaz, this is a HUGE help.  I really appreciate you listing this and our team will be investigating this ASAP.

                         

                        This entire app predates my employment with the company, but we're slowly updating it and bringing it up to modern times.  You gave us a great lead on ways of improving this substantially.