3 Replies Latest reply on Nov 6, 2012 10:04 AM by Stylianos Koussouris

    Starting Server from Domain authentication/remoting error

    Stylianos Koussouris Newbie

      I have 2 VMs and 4 instances to be run/controlled in those 2 VMs by the DC in VM1 (the configuration is described here https://community.jboss.org/thread/213010)

       

      In my local setup of 2 pcs I have verified the setup works. However when I go into the staging environment I get the following in the logs when I try to start the SEL-1 instance in the selfcare-group from the DC

       

       

      {code}
      10:33:15,070 DEBUG [org.jboss.remoting.remote.client] (Remoting "SELHostControllerAdmin:sel-2:MANAGEMENT" read-1) Client received authentication rejected for mechanism DIGEST-MD5
      10:33:15,070 ERROR [org.jboss.remoting.remote.connection] (Remoting "SELHostControllerAdmin:sel-2:MANAGEMENT" read-1) JBREM000200: Remote connection failed: javax.security.sasl.SaslException: Authentication failed: all available authentication mechanisms failed
      10:33:15,085 DEBUG [org.jboss.as.clustering.infinispan.subsystem] (ServerService Thread Pool -- 47) cluster cache container installed
      10:33:15,101 DEBUG [org.jboss.tm.usertx.UserTransactionRegistry] (MSC service thread 1-4) org.jboss.tm.usertx.UserTransactionRegistry@6ae11a87 addListener org.jboss.as.jpa.container.JPAUserTransactionListener@6094cbe2
      10:33:15,101 DEBUG [org.jboss.as.connector.logging] (MSC service thread 1-4) Starting JCA WorkManager
      10:33:15,117 DEBUG [org.jboss.as.clustering.infinispan.subsystem] (ServerService Thread Pool -- 47) Loading Infinispan defaults from jar:file:/C:/jboss-as-7.1.2.Final/modules/org/jboss/as/clustering/infinispan/main/jboss-as-clustering-infinispan-7.1.2.Final.jar!/infinispan-defaults.xml
      10:33:15,101 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC00001: Failed to start service jboss.host.controller.client: org.jboss.msc.service.StartException in service jboss.host.controller.client: java.net.ConnectException: JBAS012174: Could not connect to remote://10.48.57.68:9999. The connection failed
          at org.jboss.as.server.mgmt.domain.HostControllerServerClient.start(HostControllerServerClient.java:161) [jboss-as-server-7.1.2.Final.jar:7.1.2.Final]
          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) [rt.jar:1.6.0_31]
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [rt.jar:1.6.0_31]
          at java.lang.Thread.run(Unknown Source) [rt.jar:1.6.0_31]
      Caused by: java.net.ConnectException: JBAS012174: Could not connect to remote://10.48.57.68:9999. The connection failed
          at org.jboss.as.protocol.ProtocolChannelClient.connectSync(ProtocolChannelClient.java:154) [jboss-as-protocol-7.1.2.Final.jar:7.1.2.Final]
          at org.jboss.as.server.mgmt.domain.HostControllerServerConnection.openChannel(HostControllerServerConnection.java:158) [jboss-as-server-7.1.2.Final.jar:7.1.2.Final]
          at org.jboss.as.server.mgmt.domain.HostControllerServerConnection.connect(HostControllerServerConnection.java:86) [jboss-as-server-7.1.2.Final.jar:7.1.2.Final]
          at org.jboss.as.server.mgmt.domain.HostControllerServerClient.start(HostControllerServerClient.java:135) [jboss-as-server-7.1.2.Final.jar:7.1.2.Final]
          ... 5 more
      Caused by: javax.security.sasl.SaslException: Authentication failed: all available authentication mechanisms failed
          at org.jboss.remoting3.remote.ClientConnectionOpenListener$Capabilities.handleEvent(ClientConnectionOpenListener.java:315) [jboss-remoting-3.2.7.GA.jar:3.2.7.GA]
          at org.jboss.remoting3.remote.ClientConnectionOpenListener$Capabilities.handleEvent(ClientConnectionOpenListener.java:214) [jboss-remoting-3.2.7.GA.jar:3.2.7.GA]
          at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:72) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.channels.TranslatingSuspendableChannel.handleReadable(TranslatingSuspendableChannel.java:189) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.channels.TranslatingSuspendableChannel$1.handleEvent(TranslatingSuspendableChannel.java:103) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:72) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.channels.TranslatingSuspendableChannel.handleReadable(TranslatingSuspendableChannel.java:189) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.ssl.JsseConnectedSslStreamChannel.handleReadable(JsseConnectedSslStreamChannel.java:180) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.channels.TranslatingSuspendableChannel$1.handleEvent(TranslatingSuspendableChannel.java:103) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:72) [xnio-api-3.0.3.GA.jar:3.0.3.GA]
          at org.xnio.nio.NioHandle.run(NioHandle.java:90)
          at org.xnio.nio.WorkerThread.run(WorkerThread.java:184)
          at ...asynchronous invocation...(Unknown Source)
          at org.jboss.remoting3.EndpointImpl.doConnect(EndpointImpl.java:270) [jboss-remoting-3.2.7.GA.jar:3.2.7.GA]
          at org.jboss.remoting3.EndpointImpl.doConnect(EndpointImpl.java:251) [jboss-remoting-3.2.7.GA.jar:3.2.7.GA]
          at org.jboss.remoting3.EndpointImpl.connect(EndpointImpl.java:349) [jboss-remoting-3.2.7.GA.jar:3.2.7.GA]
          at org.jboss.remoting3.EndpointImpl.connect(EndpointImpl.java:337) [jboss-remoting-3.2.7.GA.jar:3.2.7.GA]
          at org.jboss.as.protocol.ProtocolChannelClient.connect(ProtocolChannelClient.java:114) [jboss-as-protocol-7.1.2.Final.jar:7.1.2.Final]
          at org.jboss.as.protocol.ProtocolChannelClient.connectSync(ProtocolChannelClient.java:124) [jboss-as-protocol-7.1.2.Final.jar:7.1.2.Final]
          ... 8 more
      {code}
      

       

      I have tried to see if it is a n/w issue

      a) Disabled the firwall in VM1

      b) Telnet from VM1 to 10.48.57.68:9999 (works)

      c) Telnet from remote to 10.48.57.68:9999 (fails) (could it be related?)

       

      I am unsure if it is related to n/w or otherwise.