2 Replies Latest reply on Nov 14, 2012 9:32 PM by Benson Fung

    RHQ cannot discover Tomcat6

    Benson Fung Newbie

      Hi,

       

      Here is the configuration.

       

      There is apache at the front which connect to a tomcat behind.  The http request is routed by the apache to the tomcat.

       

      Right now, the tomcat is started via an account, a_tom1, with JMX server as well.

       

      The rhq-agent is installed into the same box(linux box) and started up by another account, cqeq

       

      The rhq server is running in another box and it can connect with the agent successfully.  The rhq server also discovers the apache, but cannot discover tomcat.

       

      Can anyone tell me what is the problem here?  Should the tomcat and the rhq-agent be run by the same user account?  OR the tomcat should be responsible for sitting at the front to accept http request?  I don't know.  Please help.

       

       

      Thanks

      Benson

        • 1. Re: RHQ cannot discover Tomcat6
          Elias Ross Master

          The way that the agent discovers Tomcat is using a process scan.

           

            <process-scan
               name="Tomcat"
               query="process|basename|match=^java.*,arg|org.apache.catalina.startup.Bootstrap|match=.*" />

           

          Once it sees the process it tries to connect using JMX. If your agent isn't the same user, it will need to connect using JMX. The port should be exposed on the command line. The JVM settings I use are:

           

          -Dcom.sun.management.jmxremote

          -Dcom.sun.management.jmxremote.port=8889

          -Dcom.sun.management.jmxremote.ssl=false

          -Dcom.sun.management.jmxremote.authenticate=false

          -Dcom.sun.management.jmxremote.local.only=true

          • 2. Re: RHQ cannot discover Tomcat6
            Benson Fung Newbie

            Thanks, Elias.

             

            BTW, would you tell me where to put this xml fragment?

             

             

            Thanks