0 Replies Latest reply on Nov 14, 2012 10:35 AM by Erwin Etchart

    Jboss 4.2.3 + EAR + EJB + WS

    Erwin Etchart Newbie

      Hi, I been trying to integrate arquillian into my EJB Web Services exposed method without succeed.

      The server starts succefully but when the ear module is deployed throws an exception "Cannot find service endpoint target".

      I noted that the name of deployed module is diferent as usually is, arquillian has added jbossas-4-managed as part of the name.

       

      jbossas-4-managed_my-ear.ear

       

      I have the following dependecies to arquillian in the pom.

       

       

      <dependency>
                                    <groupId>org.jboss.arquillian.container</groupId>
                                    <artifactId>arquillian-jbossas-managed-4.2</artifactId>
                                    <version>1.0.0.CR3</version>
                                    <scope>test</scope>
                          </dependency>
      
      
                          <dependency>
                                    <groupId>org.jboss.jbossas</groupId>
                                    <artifactId>jboss-server-manager</artifactId>
                                    <version>1.0.3.GA</version>
                                    <scope>test</scope>
                          </dependency>
      
      
                          <dependency>
                                    <groupId>org.jboss.spec</groupId>
                                    <artifactId>jboss-javaee-6.0</artifactId>
                                    <version>1.0.0.Final</version>
                                    <type>pom</type>
                                    <scope>provided</scope>
                          </dependency>
      
      
      
      
                          <dependency>
                                    <groupId>org.jboss.arquillian.junit</groupId>
                                    <artifactId>arquillian-junit-container</artifactId>
                                    <scope>test</scope>
                          </dependency>
      
      
                          <dependency>
                                    <groupId>org.jboss.client</groupId>
                                    <artifactId>jbossall-client</artifactId>
                                    <version>4.2.1.GA</version>
                                    <scope>provided</scope>
                          </dependency>
      
      
                          <dependency>
                                    <groupId>org.jboss.deployers</groupId>
                                    <artifactId>jboss-deployers-client</artifactId>
                                    <version>2.2.2.GA</version>
                                    <scope>test</scope>
                          </dependency>
      
      
      
      
                </dependencies>
      
      
                <dependencyManagement>
                          <dependencies>
                                    <dependency>
                                              <groupId>org.jboss.arquillian</groupId>
                                              <artifactId>arquillian-bom</artifactId>
                                              <version>1.0.2.Final</version>
                                              <scope>import</scope>
                                              <type>pom</type>
                                    </dependency>
                          </dependencies>
                </dependencyManagement>
      
      

       

       

      my arquillian.xml

       

       

          <container  qualifier="jbossas-4-managed" default="true"  >
              <configuration>
                  <property name="jbossHome">....../jboss-4.2.3.GA</property>
                  <property name="httpPort">8084</property>
                  <property name="bindAddress">localhost</property>
                  <property name="profileName">default</property>
                  <property name="urlPkgPrefix">........</property>
                  <property name="startupTimeoutInSeconds">200</property>         
              </configuration>
          </container>
      
      

       

       

      @Deployment
                public static EnterpriseArchive createTestArchive() {
                          JavaArchive jar = ShrinkWrap.create(JavaArchive.class, "my-ejb.jar")
                                              .addPackage("...a few packages added....")
                                              .addClass("...a few classes added...."
      );
      
                          EnterpriseArchive arch = ShrinkWrap.create(EnterpriseArchive.class, "my-ear.ear")
                                              .addAsModule(jar)
                                              .setApplicationXML("application.xml");
      
                          return arch;
                }
      
      

       

       

      Just if anybody knows please help....