0 Replies Latest reply on Nov 16, 2012 4:14 AM by Milan Szabo

    Custom JSF library

    Milan Szabo Newbie

      Hello all, I have a problem with one specific JSF library in my WELD test project. I have installed WELD example from this page http://www.seamframework.org/Documentation/CDIQuickstartForMavenUsers  - it is called "Weld quick start for Maven users" Example runs great on my JBOSS 7. I have successfuly added RichFaces library which works well actually I was surprised that I didnt have to modify my web.xml to make them work.

       

      I am used to use JSF library htmLib.jar - from http://jsftutorials.net/htmLib  it is simple library where you have JSF equivalents for all HTML tags but with "rendered" attribute. I have to merge existing project to Seam3, JSF2 and I dont want to redesign all my pages to live without these components so I have decided to put that library into it but it does not work at all.

       

      These are my steps ..

       

      1. library htmLib.jar added into lib folder  in WEB-INF (the same place where richfaces are)

      2. htmLib.taglib.xml added to WEB-INF root

      3. Added to web.xml

          <context-param>

              <param-name>facelets.LIBRARIES</param-name>

              <param-value>/WEB-INF/htmLib.taglib.xml;</param-value>

          </context-param>

       

      4. And into my xhtml file I have added xmlns:htm="http://jsftutorials.net/htmLib" (the same uri as in older version of my project where it works fine)

       

      If I run this and try to test that library no error is fired at all but no HTML rendered as well In firebug I see just something like that "<htm:table><htm:tr><htm:td>text</htm:td></htm:tr></htm:table>

       

      I dont have any clue what is configured wrong - old project is facelets as well and this librarz works great I really dont want to miss that nice functionality, do you someone see any reason why It doesnot work ?