5 Replies Latest reply on May 4, 2014 4:30 PM by Bartosz Majsak

    ResourceAdapterArchive deployment error

    le2tbomi Newbie

      Hi all,

       

      When i try to deploy a ResourceAdapterArchive, i get this error

       

      java.lang.IllegalArgumentException: org.jboss.arquillian.protocol.servlet.v_3.ServletProtocolDeploymentPackager can not handle archive of type org.jboss.shrinkwrap.impl.base.spec.ResourceAdapterArchiveImpl

       

      I you want the stack trace, i can paste it here, but think the message is explicit.

       

      The code is like this :

       

      @Deployment(name="resource", order = 1)
          public static ResourceAdapterArchive createResourceArchive() throws IOException, XmlPullParserException {
              ResourceAdapterArchive result = ShrinkWrap.create(ResourceAdapterArchive.class, RAR_NAME_ARCHIVE);
      
              result.addAsLibraries(ArquillianArchiveHelper.getInstance().getResolver().resolve("group:ra-ftp:1.0.0-SNAPSHOT").withTransitivity().as(File.class));
              result.addAsManifestResource(new ByteArrayAsset("<connector xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xsi:schemaLocation=\"http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/connector_1_5.xsd\" version=\"1.6\"/>".getBytes()), "ra.xml");
      
              return result;
          }
      

       

      And the dependencyManagement section in pom is like this :

       

      <dependencyManagement>
              <dependencies>
                  <dependency>
                      <groupId>org.jboss.shrinkwrap.resolver</groupId>
                      <artifactId>shrinkwrap-resolver-bom</artifactId>
                      <version>2.0.0-alpha-4</version>
                      <scope>import</scope>
                      <type>pom</type>
                  </dependency>
                  <dependency>
                      <groupId>org.jboss.arquillian</groupId>
                      <artifactId>arquillian-bom</artifactId>
                      <version>1.0.3.Final</version>
                      <scope>import</scope>
                      <type>pom</type>
                  </dependency>
              </dependencies>
          </dependencyManagement>
      

       

      Finally, i use glassfish 3.1 as container.

       

      Someone has an idea to solve this problem ? I didn't found on google error like this and i have looked in ironjacamar but it seems that wouldn't help.