0 Replies Latest reply on Nov 26, 2012 12:31 PM by Paul Keogh

    Drools Guvnor needs Spring pre-installed?

    Paul Keogh Novice

      Hi,

       

      I've just installed Drools 5.5 onto Tomcat 6 - all good.

       

      I'm trying to upload a JAR containing POJOs that define a domain model but Tomcat is throwing an exception;

       

      Nov 26, 2012 1:43:55 PM org.apache.catalina.core.StandardWrapperValve invoke

      SEVERE: Servlet.service() for servlet AssetFileServlet threw exception

      java.lang.ClassNotFoundException: org.springframework.jdbc.core.RowMapper

          at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1680)

          at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1526)

          at java.lang.Class.forName0(Native Method)

          at java.lang.Class.forName(Class.java:264)

       

      I've googled extensively but can't see any obvious pointers.

       

      Thanks,