2 Replies Latest reply on Aug 14, 2002 5:08 PM by catman

    JBoss 3.0 CMP 2.0 Table <XXX> already exists

    catman Newbie

      Hi,
      We are trying to migrate to JBoss 3.0 and are having some trouble at deploy time. Here is the summary:
      1. When we deploy we get the following output:

      15:41:00,404 INFO [ProviderContentBean] Table 'PROVIDERCONTENT' already exists

      2. We later get a javax.ejb.FinderExcption stating:
      "Table of view does not exist".

      3. After inspecting the DB, the table PROVIDERCONTENT indeed does not exist.

      We are using JBoss-3.0.0_tomcat-4.0.3. The DB is oracle 8i.

      Here are a couple of relevant snippets:

      From oracle-service.xml:



      AdminPool



      <config-property name="ConnectionURL" type="java.lang.String">jdbc:oracle:thin:@10.100.200.136:1521:demo</config-property>
      <config-property name="DriverClass" type="java.lang.String">oracle.jdbc.driver.OracleDriver</config-property>
      <config-property name="UserName" type="java.lang.String">demo</config-property>
      <config-property name="Password" type="java.lang.String">PASSWORD</config-property>




      <!--Below here are advanced properties -->
      <!--hack-->
      <depends optional-attribute-name="OldRarDeployment">jboss.jca:service=RARDeployment,name=JBoss LocalTransaction JDBC Wrapper....




      From jbosscmp-jdbc.xml:

      <jbosscmp-jdbc>

      java:/AdminPool
      <datasource-mapping>Oracle8</datasource-mapping>
      <create-table>true</create-table>
      <remove-table>false</remove-table>
      <read-only>false</read-only>

      <enterprise-beans>
      ....


      Any insight would be greatly appreciated.

      Cheers,
      Chad