1 Reply Latest reply on Dec 3, 2012 12:54 AM by Stephen Coy

    Apache load balancer receives ajp request from JBoss7

    Vikie Pan Newbie

      Hi - I have recently udpated my application from  JBoss 5.1 to JBoss 7.1. Everything looks fine except the below problem Can someone please help me.

       

      I have apache load balancer running on top my app servers jboss 7. All request are going via apache load balancer and looks okay..

       

      When i do a RedirectView from my app jboss 7 server ,,, return new ModelAndView(new RedirectView(getSuccessView()+"?tid="+ticketId+"&newTicket=true")); i see the reqeust coming to load balancer but the header location url is ajp://myapp.com?tid=1234&newTicket=true

       

      I'm not sure why only for  the RedirectView request from my spring based app, the load balancer receives a ajp reqeust..

       

      standalone.xml

       

      <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="127.0.0.1" native="false" instance-id="myJvmRoute">

                  <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                  <connector name="ajp" protocol="AJP/1.3" scheme="ajp"  socket-binding="ajp"/>

                  <virtual-server name="127.0.0.1" enable-welcome-root="false">

                      <alias name="127.0.0.1"/>

                  </virtual-server>

              </subsystem>

       

      Can anyone please help me to understand this..

       

       

      Thanks

      Vikie