7 Replies Latest reply on Dec 9, 2013 2:39 AM by Oliver Katzer

    Could not register a EJB receiver for connection to remote

    jayasiv Newbie

      Our application is a client server desktop application using EJB. Recently we migrated from JBoss 4.2.3 to JBoss 7.1.1 final. We are getting the following error:

       

      08:50:16,300 WARN  [ConfigBasedEJBClientContextSelector] Could not register a EJB receiver for connection to remote://jboss-p1:4447

      java.lang.RuntimeException: Operation failed with status WAITING

              at org.jboss.ejb.client.remoting.IoFutureHelper.get(IoFutureHelper.java:93)

              at org.jboss.ejb.client.remoting.ConfigBasedEJBClientContextSelector.setupEJBReceivers(ConfigBasedEJBClientContextSelector.java:121)

              at org.jboss.ejb.client.remoting.ConfigBasedEJBClientContextSelector.<init>(ConfigBasedEJBClientContextSelector.java:78)

              at org.jboss.ejb.client.EJBClientContext.<clinit>(EJBClientContext.java:77)

              at org.jboss.ejb.client.EJBInvocationHandler.doInvoke(EJBInvocationHandler.java:120)

              at org.jboss.ejb.client.EJBInvocationHandler.invoke(EJBInvocationHandler.java:104)

       

      Once i restart the JBoss server, it starts working fine again. Not sure if there is any configuration that needs to be done on the server side. When i checked the JBoss forums, it said this issue is fixed in JBoss 7.1.1 final.

       

      Also i see this error messge in the server log appearing several times.

       

      ERROR [org.jboss.remoting.remote.connection] (Remoting "jboss-p1" read-1) JBREM000200: Remote connection failed: java.io.IOException: An existing connection was forcibly closed by the remote host

       

      Here is my ejb client property file:

       

      endpoint.name=client-endpoint

      remote.connectionprovider.create.options.org.xnio.Options.SSL_ENABLED=false

      remote.connections=default

      remote.connection.default.host=jboss-p1

      remote.connection.default.port=4447

      remote.connection.default.connect.options.org.xnio.Options.SASL_POLICY_NOANONYMOUS=false