If I have a uni-directional relationship MUST I NAME IT BASED ON THE BEAN TYPE ???
For bean NodeBean, I want (must) name the getter/setters as
public abstract NodeLocal getSOURCENode();
public abstract void setSOURCENode(NodeLocal InSourceNode); // ???
But the deployer will ONLY let me name it based on the bean TYPE as such:
public abstract NodeLocal getNode();
public abstract void setNode(NodeLocal InNode);
Is there a way to make the first setter/gettter (getSOURCENode())namings hold?
I don't know where this idea came from. The only rules are presented in the EJB spec. If I remember the suff after the get/ set must match (each other) and must begin with a capitol letter. Other then that it must be a valid Java name (it is a method name after all).