6 Replies Latest reply on Jan 13, 2013 10:55 AM by Lukáš Fryč

    Difficulties while doing preview of Arquillian web pages by awestruct

    Stefan Miklosovic Novice

      Hi,

       

      I would like to look around Arquillian web page and maybe translate something or do some fixes if I find something to fix. So I followed this how-to https://github.com/arquillian/arquillian.github.com and after setting all up (which was not as straightforward as declared but I did it in the end ...), I executed "awestruct -d" on the development branch but after entering localhost:4242 no page is shown to me and this error is displayed in the logs:

       

       

      [~/src/java/REPO/arquillian.github.com]$ awestruct -d
      Using profile: development
      Generating site: http://localhost:4242
      Using cloned repository /tmp/arqrepos/arquillian-container-cloudbees
      Using cloned repository /tmp/arqrepos/arquillian-container-glassfish
      Using cloned repository /tmp/arqrepos/arquillian-container-jbossas
      Using cloned repository /tmp/arqrepos/arquillian-container-jetty
      
      .... (and so on)
      
      >> Thin web server (v1.4.1 codename Chromeo)
      >> Maximum connections set to 1024
      >> Listening on 0.0.0.0:4242, CTRL+C to stop
      !! Unexpected error while processing request: Is a directory
      

       

      Does somebody know how to figure this out? I guess Arquillian home page should be displayed after visiting localhost:4242 but it is not the case.

       

      I also noticed there are logs like "Used github mapping to lookup github_id xyz" or "Manually adding xyz as a contributor". I guess these entries are specified here https://github.com/smiklosovic/arquillian.github.com/tree/develop/_config Should I add myself to that list and make pull request or how is this workflow done? I am already at github ...

       

      Thx a lot

        • 1. Re: Difficulties while doing preview of Arquillian web pages by awestruct
          Stefan Miklosovic Novice

          Well, it was my fault .... i did not specify "-g" switch so the _site dir was empty ... I suggest to add that "-g" switch to the original how-to to not confuse people. Oh wait ... but I can do it too!

          • 2. Re: Difficulties while doing preview of Arquillian web pages by awestruct
            Aslak Knutsen Master

            hmm, that's a bit odd. You shouldn't need the -g when using -d

             

            Which awestruct version are you running?

            • 3. Re: Difficulties while doing preview of Arquillian web pages by awestruct
              Aslak Knutsen Master

              The Identity extension in Awstruct should normally pick up the user info based on git commits / github users etc, just adding your github id as author: or translator: 'should' work..

               

              There is tho a little chicken and egg issue there, since it's fetching data from github, the commit has to be in the repo on github before it can find the user, so for new users it won't work. You can add your self to the _config/identities.yml but leave it out of the commit. Then when it's pushed upstream it will all just work

              • 4. Re: Difficulties while doing preview of Arquillian web pages by awestruct
                Stefan Miklosovic Novice

                I am not sure I am not using that computer right now but I remember 0.4.7 was the version of awestruct. At least I am sure it is > 0.4. There is > 0.2.something in prerequisities so it should be ok.

                 

                I noticed that there is a "bug" reported like you have to "touch" some file in order to build it or generate the site as such. I remember I did something like "find . | xargs touch; awestruct -d -g" and then it worked properly ... But it is weird indeed. I cloned repos few times from scratch and did as written in README, step by step, but nothing helped, only touching did the trick.

                 

                Maybe I am just unlucky and I am using some weird combination of all software.

                 

                Firstly I did not follow the "bundle install" way and I did it by gems way but I had to install additional gems on my own in order to satisfy awestruct, I can't remember which gems I installed, I guess "vp8" and "execjs" because awestruct said it cannot find any javascript runtime or something like that ... I was installing it on "ruby free" centos 6.3 so it may be a case this is quite repeatable for other people too.

                 

                I also installed additional gems as advised in the README

                • 5. Re: Difficulties while doing preview of Arquillian web pages by awestruct
                  Lukáš Fryč Master

                  Note that I have tried to use Awestruct (which would be able to build Arquillian page) from clean Fedora 17 installation with no success:

                   

                  !! Unexpected error while processing request: Is a directory

                   

                  Just for information, there are additional steps which were necessary to do:

                   

                  1. yum groupinstall "Development Tools"
                  2. compile node/npm from github source http://www.davidhampgonsalves.com/2012/10/Install-Node-js-NPM-on-Fedora-Core-17
                  3. # yum install libxml2 libxml2-devel libxslt libxslt-devel
                  4. # gem install ri_cal tzinfo

                   

                  I will investigate further.

                  • 6. Re: Difficulties while doing preview of Arquillian web pages by awestruct
                    Lukáš Fryč Master

                    The issue which I was facing was that _site wasn't generated properly (which is the path Awestruct's handled Thin server points to).

                    It seems when some error occurs during a build of the page, build skips to serve the generated content, which is in lot of cases nothing.

                     

                    What was the real case?

                     

                    • There is limit for Github API calls (60 requests per IP address) which prevents to checkout various page content from GitHub anonymously
                    • when you add ~/.github-auth , you will get much more benevolent limits: 5000
                    • however there are still some URLs which does not reflect this setting and tries to request GitHub API anonymously
                      • I'll sent pull request
                    • seems that for listing members of teams (translator, core) using GitHub API, you need to be granted with permission
                      • request fails on Permission denied for me

                     

                    I will make sure my experience with installation is reflected to README and I'll open issue for updating given URLs.