2 Replies Latest reply on Jan 25, 2013 3:42 PM by Justin Bertram

    HornetQ and JMSBridge example:   Deployment "TransactionManager" is in error due to: java.lang.ClassNotFoundException: com.arjuna.ats.internal.jta.transaction.arjunacore.TransactionManagerImple

    jaapvanderherberg Newbie

      I am trying to run HornetQ 2.2.14 with a JMSBridge. Following the configuration (for server1/target) in hornetq-2.2.14.Final/examples/jms/jms-bridge/readme.html

       

      The HornetQ JMSBridge example doesn't seem to work out-of-the box and I'm not sure how to fix this (and if I should be fixing this).

      I have tried this on three different servers: a server running CentOS  5.8 (with Oracle JDK java version 1.7.0_04), a server running CentOS  5.8 (with OpenJDK java version 1.6.0_22) and a server running CentOS  6.3 (with Oracle JDK java version 1.7.0_07).

       

      I'm guessing that maybe libraries need to be added to the HornetQ installation but if so, which libraries do we need: version, source (URL)?

       

      Steps to reproduce:

      1. Installed HornetQ 2.2.14

      2. Modified configuration in stand-alone/non-clustered/ according to hornetq-2.2.14.Final/examples/jms/jms-bridge/readme.html just for server1/target

      3. Now when I start HornetQ (with the JMSBridge configured) I get the following error:

      * [main] 13-Dec 12:30:54,392 SEVERE [HornetQBootstrapServer]  Failed to start server

      java.lang.IllegalStateException: Incompletely deployed:

      DEPLOYMENTS IN ERROR:

        Deployment "JMSBridge" is in error due to: java.lang.NoClassDefFoundError: javax/transaction/TransactionManager

        Deployment "TransactionManager" is in error due to: java.lang.ClassNotFoundException: com.arjuna.ats.internal.jta.transaction.arjunacore.TransactionManagerImple

          at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.internalValidate(AbstractKernelDeployer.java:278)

          at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.validate(AbstractKernelDeployer.java:174)

          at org.hornetq.integration.bootstrap.HornetQBootstrapServer.bootstrap(HornetQBootstrapServer.java:158)

          at org.jboss.kernel.plugins.bootstrap.AbstractBootstrap.run(AbstractBootstrap.java:83)

          at org.hornetq.integration.bootstrap.HornetQBootstrapServer.run(HornetQBootstrapServer.java:116)

          at org.hornetq.integration.bootstrap.HornetQBootstrapServer.main(HornetQBootstrapServer.java:73)

      Exception in thread "main" java.lang.IllegalStateException: Incompletely deployed:

      * [hornetq-shutdown-thread] 13-Dec 12:31:35,94 INFO [HornetQBootstrapServer]  Stopping HornetQ Server...

       

      4. Tried to find libraries for the TransactionManager;

      Added the following libraries to the lib/ directory (might work according to https://community.jboss.org/thread/213026):

       

      This seems to fix the TransactionManager issue but now HornetQ is unable to start because of:

      Deployment "JMSBridge" is in error due to: java.lang.NoSuchMethodError: org.jboss.logging.Logger.getMessageLogger(Ljava/lang/Class;Ljava/lang/String;)Ljava/lang/Object;

      (maybe a conflict because of the added libraries?)

       

      Without the  JMSBridge configured there is no problem and I am perfectly able to start HornetQ.

       

      Has anyone seen this before?

      Any help would be greatly appreciated!