5 Replies Latest reply on Dec 29, 2008 7:05 AM by jaikiran pai

    Takes forever to start up on Mac OS X 10.5.5

    mburbidg Newbie

      I've been using JBoss 4.x and Mac OS X for my development environment of a couple of years now. I just recently download JBoss 5.0 GA and tried running it. It takes about a minute for JBoss 5.0 GA to startup. This is unmodified, out of the box. I've tried all the configurations and they are all the same.

      The following line is written to the console just before it seems to stall out:

      14:27:40,606 INFO [WebService] Using RMI server codebase:

      Then twenty seconds later this comes out to the console:

      14:28:08,001 INFO [NativeServerConfig] JBoss Web Services - Stack Native Core
      14:28:08,001 INFO [NativeServerConfig] 3.0.4.SP1

      Twenty more seconds and we get this:

      14:28:41,262 INFO [JMXConnectorServerService] JMX Connector server: service:jmx:rmi://
      14:28:44,348 INFO [MailService] Mail Service bound to java:/Mail

      Then after awhile we get this:

      14:28:55,782 WARN [JBossASSecurityMetadataStore] WARNING! POTENTIAL SECURITY RISK. It has been detected that the MessageSucker component which sucks messages from one node to another has not had its password changed from the installation default. Please see the JBoss Messaging user guide for instructions on how to do this.
      14:28:55,800 WARN [AnnotationCreator] No ClassLoader provided, using TCCL: org.jboss.managed.api.annotation.ManagementComponent

      Then a bunch more stuff very quickly and finally the startup message:

      14:29:10,138 INFO [ServerImpl] JBoss (Microcontainer) [5.0.0.GA (build: SVNTag=JBoss_5_0_0_GA date=200812041714)] Started in 1m:39s:397ms

      I tried it on Windows and it launches immediately. Is there some new configuration that I need to do on Macintosh?