1 Reply Latest reply on Dec 21, 2012 3:06 AM by Jean-Frederic Clere

    mod_cluster 1.2 + JBoss AS 7.1.3, mod_cluster_manager sees no nodes

    Phillip Rhodes Newbie

      Hi all, I'm trying to test  a simple two node cluster using mod_cluster 1.2 and JBoss AS 7.1.3.  I have Apache httpd and one JBoss instance running on server "betty1" with IP 192.168.41.180 and another JBoss node on server "betty2" with IP 192.168.41.181.   JBoss is running in domain mode and I have deployed a trivial cluster-demo app with a <distributable /> tag.  So far, I'm unable to have mod_cluster_manager report that it sees any of the nodes in the cluster.   I already gave up on using server advertise, which strikes me as fairly brittle from other forum posts and what-not, so I decided to fall back to a manually specified proxy-list.  Unfortunately, even that doesn't work.   I'm hoping this is just some missed config option or something on my part, so I'll share my config her and hope someone can help.

       

      httpd.conf:

       

      {code:xml}

      # MOD_CLUSTER_ADDS                                                                                                                                                                                                  

      # Adjust to you hostname and subnet.                                                                                                                                                                                

      <IfModule manager_module>

        Listen 192.168.41.180:6666

        ManagerBalancerName mycluster

        <VirtualHost 192.168.41.180:6666>

          ServerName betty1

          <Location />

           Order deny,allow

           Deny from all

           Allow from 192.168.

          </Location>

       

          KeepAliveTimeout 300

          MaxKeepAliveRequests 0

      #    ServerAdvertise On                                                                                                                                                                                             

                             # http://@IP@:6666                                                                                                                                                                           

      #   AdvertiseFrequency 5                                                                                                                                                                                           

      #   AdvertiseSecurityKey secret                                                                                                                                                                                    

          #AdvertiseGroup @ADVIP@:23364                                                                                                                                                                                   

          EnableMCPMReceive

       

          <Location /mod_cluster_manager>

             SetHandler mod_cluster-manager

             Order deny,allow

             Deny from all

             Allow from 192.168.

          </Location>

       

        </VirtualHost>

      </IfModule>

       

      {code}

       

       

       

       

       

       

      domain.xml

       

       

       

      {code}

      <subsystem xmlns="urn:jboss:domain:modcluster:1.1">

                      <mod-cluster-config advertise-socket="modcluster" connector="ajp" proxy-list="192.168.41.180:6666" >

                          <dynamic-load-provider>

                              <load-metric type="busyness"/>

                          </dynamic-load-provider>

                      </mod-cluster-config>

                  </subsystem>

      {code}

       

       

      Thoughts or suggestions?