2 Replies Latest reply on Jan 4, 2013 3:04 PM by Shobhit Tyagi

    jBPM bpmn2user web application

    Shobhit Tyagi Master

      I tried to run the web application that bpmn2user posted some time back in his blog. It worked amazingly fine.

      But the moment I changed the data source properties to point it to DB2. It started giving me problems.

      First run of tomcat, it gave me table not found warnings. Which makes sense. and it created the tables.

      Next run, nothing in the console. No error, no warning.

      But while creating a process, it displayed the following errors :

       

      Caused by: com.ibm.db2.jcc.am.co: DB2 SQL Error: SQLCODE=-302, SQLSTATE=22001, S

      QLERRMC=null, DRIVER=3.57.82

       

      javax.persistence.PersistenceException: org.hibernate.exception.DataException: could not update: [org.jbpm.persistence.processinstance.ProcessInstanceInfo#2]

       

      java.lang.NoClassDefFoundError: javax/mail/Address

       

      Caused by: javax.management.InstanceNotFoundException: bitronix.tm:type=Transaction,Gtrid=3137322E32392E3136352E3231350000013C01623C0200000006

       

      Did anyone try a similar thing or might have fallen into these exceptions sometime?