5 Replies Latest reply on Jan 4, 2013 9:24 AM by Keith Babo

    How to fix installation of JBDS 6.0.0.GA?

    Friso V Newbie

      Hi all,

       

      I've just installed JBoss developer studio. Version details:

      {noformat}

      Version: 6.0.0.GA

      Build id: GA-v20121206-1855-B186

      Build date: 20121206-1855

      {noformat}

       

      Per https://docs.jboss.org/author/display/SWITCHYARD/Getting+Started#GettingStarted-InstallingEclipseTooling I downloaded switchyard-site-assembly-0.6.0.Final.zip. In there is a feature.xml that states:

      {code:xml}<import feature="org.maven.ide.eclipse.wtp.feature" version="0.14.0" match="greaterOrEqual"/>{code}

       

      From the zip I try to install the SwitchYard tools. I than get the error:

       

      {noformat}

      Cannot complete the install because one or more required items could not be found.

        Software being installed: SwitchYard Tools 0.6.0.v20121108-2350-H217-Final (org.switchyard.tools.feature.feature.group 0.6.0.v20121108-2350-H217-Final)

        Missing requirement: SwitchYard Tools 0.6.0.v20121108-2350-H217-Final (org.switchyard.tools.feature.feature.group 0.6.0.v20121108-2350-H217-Final) requires 'org.maven.ide.eclipse.wtp.feature.feature.group 0.14.0' but it could not be found

      {noformat}

       

      In my installed software list I've got:


      m2e-wtp - Maven Integration for WTP (Incubation)0.16.0.20120914-0945org.eclipse.m2e.wtp.feature.feature.groupEclipse.org - m2e-wtp

       

      Can my setup be fixed? If so, how?

       

      Groeten,

       

      Friso