1 Reply Latest reply on Jan 15, 2013 2:14 AM by clairelin

    Maven plugin to execute wsconsume

    Mylos Kathos Master

      Hello !

      I need to generate Web Service artifacts for my WSClient. I've found a Maven plugin which could be used in replacement of wsconsume:

       

      <plugin>

          <groupId>org.jboss.ws.plugins</groupId>

          <artifactId>maven-jaxws-tools-plugin</artifactId>

          <version>1.0.0.GA</version>

          <configuration>

            <wsdls>

              <wsdl>http://localhost:8080/webserviceapp/Booker?wsdl </wsdl>

         

            </wsdls>

            <targetPackage>foo.bar</targetPackage>

            <extension>true</extension>

          </configuration>

          <executions>

            <execution>

              <goals>

                <goal>wsconsume</goal>

              </goals>

            </execution>

      ....

      </plugin>

       

      When I launch maven:

      mvn -Dgoal=wsconsume

       

      I get the following error:

      Downloading: http://repo1.maven.org/maven2/org/jboss/ws/plugins/maven-jaxws-tools-plugin/1.0.0.GA/maven-jaxws-tools-plugin-1.0.0.GA.pom

      [INFO] ------------------------------------------------------------------------

      [INFO] BUILD FAILURE

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 1:21.252s

      [INFO] Finished at: Fri Jan 11 15:10:13 CET 2013

      [INFO] Final Memory: 4M/15M

      [INFO] ------------------------------------------------------------------------

      [ERROR] Plugin org.jboss.ws.plugins:maven-jaxws-tools-plugin:1.0.0.GA or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.jboss.ws.plugins:maven-jaxws-tools-plugin:jar:1.0.0.GA: Could not transfer artifact org.jboss.ws.plugins:maven-jaxws-tools-plugin:pom:1.0.0.GA from/to central (http://repo1.maven.org/maven2): Connect times out -> [Help 1]

       

      Do I need to point to another repository to get this working ?

      Thanks

      Mylos

        • 1. Re: Maven plugin to execute wsconsume
          Newbie

          For your reference, mine is:

           

          {code:xml}

           

          ........

           

                      <build>

                              <pluginManagement>

                              </pluginManagement>

                              <plugins>

                                        <plugin>

                                                  <artifactId>maven-compiler-plugin</artifactId>

                                                  <version>2.3.2</version>

                                                  <configuration>

                                                            <source>1.5</source>

                                                            <target>1.5</target>

                                                  </configuration>

                                        </plugin>

            <plugin>

                                                  <groupId>org.jboss.ws.plugins</groupId>

                                                  <artifactId>maven-jaxws-tools-plugin</artifactId>

                                                  <version>1.1.0.GA</version>

                                                  <configuration>

                                                            <wsdls>

                  <wsdl>http://abc/def_ep?WSDL</wsdl>

                                                            </wsdls>

                                                            <sourceDirectory>${project.basedir}/src/main/java</sourceDirectory>

                                                            <extension>true</extension>

                                                            <verbose>true</verbose>

                                                            <goalPrefix>wsconsume</goalPrefix>

                                                  </configuration>

                                                  <executions>

                                                            <execution>

                                                                      <goals>

                                                                                <goal>wsconsume</goal>

                                                                      </goals>

                                                            </execution>

                                                  </executions>

                                        </plugin>

                              </plugins>

                    </build>

                    <dependencies>

                              <dependency>

                                        <groupId>org.jboss.spec.javax.xml.ws</groupId>

                                        <artifactId>jboss-jaxws-api_2.2_spec</artifactId>

                                        <version>2.0.0.Final</version>

                                        <scope>provided</scope>

                              </dependency>

                              <dependency>

                                        <groupId>org.jboss.ws.cxf</groupId>

                                        <artifactId>jbossws-cxf-client</artifactId>

                                        <version>4.0.0.GA</version>

                                        <scope>provided</scope>

                              </dependency>

                              <dependency>

                                        <groupId>org.jboss.ws</groupId>

                                        <artifactId>jbossws-api</artifactId>

                                        <version>1.0.0.GA</version>

                                        <scope>provided</scope>

                              </dependency>

                    </dependencies>

           

          ........

           

          {code}