10 Replies Latest reply on Mar 25, 2013 9:07 AM by Brian Wallis

    3.1 SNAPSHOT and JBoss AS7 kit issue

    Brian Wallis Master

      I've been using a 3.1 snapshot for my development for the last couple of weeks as it contains a number of fixes for issues that I need for my development.

       

      I have an arquillian integration test as part of my build and it doesn't work anymore with the snapshot build of modeshape 3.1 (just now updated from git).

       

      I get the error shown at the end of this which seems to be due to a missing jar file in the tika module, xmlbeans-2.3.0.jar, which is mentioned in the tika module.xml file. The tika module comes as part of the jboss as7 kit that is installed over jboss 7.1.1.

       

      {code:xml}

      <module xmlns="urn:jboss:module:1.1" name="org.apache.tika" slot="1.2">

          <resources>

              <resource-root path="tika-core-1.2.jar" />

              <resource-root path="tika-parsers-1.2.jar" />

              <!--All the following are specific to Tika 1.2. Should the tika version change, those need to change as well-->

              <resource-root path="asm-3.1.jar" />

              <resource-root path="apache-mime4j-core-0.7.2.jar" />

              <resource-root path="apache-mime4j-dom-0.7.2.jar" />

              <resource-root path="commons-codec-1.5.jar" />

              <resource-root path="commons-compress-1.4.1.jar" />

              <resource-root path="dom4j-1.6.1.jar" />

              <resource-root path="fontbox-1.7.0.jar" />

              <resource-root path="geronimo-stax-api_1.0_spec-1.0.1.jar" />

              <resource-root path="isoparser-1.0-RC-1.jar" />

              <resource-root path="javassist-3.11.0.GA.jar" />

              <resource-root path="jempbox-1.7.0.jar" />

              <resource-root path="juniversalchardet-1.0.3.jar" />

              <resource-root path="pdfbox-1.7.0.jar" />

              <resource-root path="poi-3.8.jar" />

              <resource-root path="poi-ooxml-3.8.jar" />

              <resource-root path="poi-ooxml-schemas-3.8.jar" />

              <resource-root path="poi-scratchpad-3.8.jar" />

              <resource-root path="tagsoup-1.2.1.jar" />

              <resource-root path="vorbis-java-core-0.1.jar" />

              <resource-root path="vorbis-java-core-0.1-tests.jar" />

              <resource-root path="vorbis-java-tika-0.1.jar" />

              <resource-root path="xmlbeans-2.3.0.jar" />

              <resource-root path="xz-1.0.jar" />

       

       

              <!-- ModeShape chooses not to include the Bouncy Castle libraries by default. These can be added by users.

              <resource-root path="bcmail-jdk15-1.45.jar" />

              <resource-root path="bcprov-jdk15-1.45.jar" />

              -->

          </resources>

      ...

      {code}

       

      I'm fairly certain that the jboss version my test is using is a standard 7.1.1 install and that the modeshape version and kit is the one I just built, this is the relevant output from my integration test

       

      {code}

      [INFO] --- maven-dependency-plugin:2.3:unpack (unpack) @ document-store-integration ---

      [INFO] Configured Artifact: org.jboss.as:jboss-as-dist:7.1.1.Final:zip

      [INFO] Configured Artifact: org.modeshape:modeshape-distribution:jbossas-71-dist:3.1-SNAPSHOT:zip

      Downloading: http://im-vm-repository:8090/artifactory/repo/org/modeshape/modeshape-distribution/3.1-SNAPSHOT/maven-metadata.xml

      [INFO] Unpacking /Users/bwallis/.m2/repository/org/jboss/as/jboss-as-dist/7.1.1.Final/jboss-as-dist-7.1.1.Final.zip to /Users/bwallis/InfoMedix/CPF4/DocumentStore/integration/target with includes "" and excludes ""

      [INFO] Unpacking /Users/bwallis/.m2/repository/org/modeshape/modeshape-distribution/3.1-SNAPSHOT/modeshape-distribution-3.1-SNAPSHOT-jbossas-71-dist.zip to /Users/bwallis/InfoMedix/CPF4/DocumentStore/integration/target/jboss-as-7.1.1.Final with includes "" and excludes ""

      {code}

       

      The error I get is

       

      {code}

      09:47:40,956 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA

      09:47:41,273 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA

      09:47:41,340 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting

      09:47:42,302 ERROR [org.jboss.as.server] JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration

                at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.server.ServerService.boot(ServerService.java:266) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:155) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_37]

      Caused by: javax.xml.stream.XMLStreamException: Failed to load module org.modeshape

                at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:154) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_1(StandaloneXml.java:305) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:127) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:100) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                ... 3 more

      Caused by: java.util.concurrent.ExecutionException: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module

                at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222) [classes.jar:1.6.0_37]

                at java.util.concurrent.FutureTask.get(FutureTask.java:83) [classes.jar:1.6.0_37]

                at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:146) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                ... 9 more

      Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module

                at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:195) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.controller.parsing.ExtensionXml.access$000(ExtensionXml.java:68) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:126) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:123) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [classes.jar:1.6.0_37]

                at java.util.concurrent.FutureTask.run(FutureTask.java:138) [classes.jar:1.6.0_37]

                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_37]

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_37]

                at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_37]

                at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.0.0.GA.jar:2.0.0.GA]

      Caused by: org.jboss.modules.ModuleLoadException: Error loading module from /Users/bwallis/InfoMedix/CPF4/DocumentStore/integration/target/jboss-as-7.1.1.Final/modules/org/apache/tika/1.2/module.xml

                at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:292) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:242) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.LocalModuleLoader.parseModuleInfoFile(LocalModuleLoader.java:138) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:122) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.Module.addPaths(Module.java:841) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.Module.link(Module.java:1181) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.Module.relinkIfNecessary(Module.java:1207) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:177) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                ... 9 more

      Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[50,52]

      Message: Failed to add resource root 'xmlbeans-2.3.0.jar' at path 'xmlbeans-2.3.0.jar'

                at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:898) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:854) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:676) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:548) [jboss-modules.jar:1.1.1.GA]

                at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:287) [jboss-modules.jar:1.1.1.GA]

                ... 20 more

       

       

      09:47:42,338 FATAL [org.jboss.as.server] JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.

      09:47:42,361 INFO  [org.jboss.as] JBAS015950: JBoss AS 7.1.1.Final "Brontes" stopped in 12ms

      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 6.167 sec <<< FAILURE!

      {code}

        • 1. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
          Horia Chiorean Master

          Hi Brian,

           

          Just had a look at our modeshape-3.1-SNAPSHOT-jbossas-71-dist.zip (built by the modeshape-distribution module) and inside the org.apache.tika.1.2 module there is a xmlbeans-2.3.0.jar file.

          When you built our AS7 kit from Maven, what command did you use ? (you need either -Pintegration or -Passembly)

          1 of 1 people found this helpful
          • 2. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
            Brian Wallis Master

            Built the snapshot with

             

            {code}

            mvn clean install -DskipTests -Dmaven.test.failure.ignore=true -s settings.xml -Passembly

            {code}

             

            but I have now updated to use the just released 3.1.0.Final instead of my snapshot and all is well.

             

            So, no idea why it failed. I will update and try another build and see if the archive is complete this time.

             

            thanks

            • 3. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
              Brian Wallis Master

              no luck. Just updated from the git repo (now tagged 3.2-SNAPSHOT) and rebuilt with either -Passembly or -Pintegration and still have the xmlbeans jar file included in the tiki modules.xml file but not in the module directory.

               

              Strange, must be something in my environment.

               

              Not a big problem, I'm happy to be using 3.1.0.Final for my builds and that is working fine.

               

              Congratulations on the new release!

               

              thanks

              • 4. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
                Brian Wallis Master

                Odd, the problem is back again.

                 

                I just built the latest 3.2-SNAPSHOT and xmlbeans-2.3.0.jar is missing from the tika module again when the modeshape distribution is unpacked into the jboss EAP 6.1 installation. If I put a copy of the xmlbeans-2.3.0.jar file into the modules/org/apache/tika/1.3 then all is well. A listing of what is in my locally built distibution zip is as follows:

                 

                 

                {code}

                % unzip -l ~/.m2/repository/org/modeshape/modeshape-distribution/3.2-SNAPSHOT/modeshape-distribution-3.2-SNAPSHOT-jbosseap-61-dist.zip | grep modules/org/apache/tika/1.3 | sort -k 4

                        0  03-21-13 12:00   modules/org/apache/tika/1.3/

                    95536  11-19-12 14:46   modules/org/apache/tika/1.3/apache-mime4j-core-0.7.2.jar

                   304810  11-19-12 14:46   modules/org/apache/tika/1.3/apache-mime4j-dom-0.7.2.jar

                    43033  11-21-12 15:32   modules/org/apache/tika/1.3/asm-3.1.jar

                    73098  11-19-12 13:55   modules/org/apache/tika/1.3/commons-codec-1.5.jar

                   241367  11-19-12 12:07   modules/org/apache/tika/1.3/commons-compress-1.4.1.jar

                    60686  11-22-12 09:31   modules/org/apache/tika/1.3/commons-logging-1.1.1.jar

                   313898  11-19-12 12:07   modules/org/apache/tika/1.3/dom4j-1.6.1.jar

                   188471  03-21-13 11:51   modules/org/apache/tika/1.3/fontbox-1.7.1.jar

                    28804  11-22-12 12:43   modules/org/apache/tika/1.3/geronimo-stax-api_1.0_spec-1.0.1.jar

                   521237  11-22-12 12:43   modules/org/apache/tika/1.3/isoparser-1.0-RC-1.jar

                   614203  11-22-12 09:49   modules/org/apache/tika/1.3/javassist-3.11.0.GA.jar

                    50942  03-21-13 11:51   modules/org/apache/tika/1.3/jempbox-1.7.1.jar

                   220813  11-22-12 12:43   modules/org/apache/tika/1.3/juniversalchardet-1.0.3.jar

                     3070  03-21-13 12:00   modules/org/apache/tika/1.3/module.xml

                  3910899  03-21-13 11:51   modules/org/apache/tika/1.3/pdfbox-1.7.1.jar

                  1820323  11-19-12 12:07   modules/org/apache/tika/1.3/poi-3.8.jar

                   933010  11-19-12 12:07   modules/org/apache/tika/1.3/poi-ooxml-3.8.jar

                  4706775  11-19-12 12:07   modules/org/apache/tika/1.3/poi-ooxml-schemas-3.8.jar

                  1186887  11-19-12 12:07   modules/org/apache/tika/1.3/poi-scratchpad-3.8.jar

                    90722  11-22-12 12:43   modules/org/apache/tika/1.3/tagsoup-1.2.1.jar

                   475853  03-21-13 11:49   modules/org/apache/tika/1.3/tika-core-1.3.jar

                   486107  03-21-13 11:49   modules/org/apache/tika/1.3/tika-parsers-1.3.jar

                    30301  11-19-12 12:07   modules/org/apache/tika/1.3/vorbis-java-core-0.1-tests.jar

                    47478  11-19-12 12:07   modules/org/apache/tika/1.3/vorbis-java-core-0.1.jar

                    14752  11-19-12 12:07   modules/org/apache/tika/1.3/vorbis-java-tika-0.1.jar

                    94672  11-19-12 12:07   modules/org/apache/tika/1.3/xz-1.0.jar

                {code}

                 

                Very odd.

                 

                My build line for modeshape was

                 

                {code}

                mvn clean install -DskipTests -Dmaven.test.failure.ignore=true -s settings.xml -Pintegration

                {code}

                • 5. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
                  Horia Chiorean Master

                  I just tried this locally (Apache Maven 3.0.3) and I have the xmlbeans-2.3.0.jar in the distribution, packaged.

                  • 6. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
                    Brian Wallis Master

                    I'm trying to chase this down as it is annoying me. Might be related to my local repository server/cache, we are using artifactory but I've moved my local ~/.m2/settings.xml file aside and the problem still occurs.

                     

                    What I see in the output is:

                     

                    {noformat}

                    [INFO] --- maven-assembly-plugin:2.2.1:single (default) @ modeshape-distribution ---

                    [WARNING] The following patterns were never triggered in this artifact inclusion filter:

                    o  'org.apache.xmlbeans:*:jar'

                     

                     

                    [WARNING] Cannot include project artifact: org.modeshape:modeshape-distribution:pom:3.2-SNAPSHOT; it doesn't have an associated file or directory.

                    {noformat}

                     

                    so it is excluding or not finding it for some reason.

                     

                    I have the following in my local repository:

                     

                    {noformat}

                    % ls /Users/bwallis/.m2/repository/org/apache/xmlbeans/xmlbeans/2.3.0

                    _maven.repositories          xmlbeans-2.3.0.jar          xmlbeans-2.3.0.jar.sha1

                    {noformat}

                     

                    which is a bit odd as there doesn't seem to be a pom file included. Not sure why.

                    • 7. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
                      Brian Wallis Master

                      I just added

                       

                      {code}

                              <dependency>

                                <groupId>org.apache.xmlbeans</groupId>

                                <artifactId>xmlbeans</artifactId>

                                <version>2.3.0</version>

                              </dependency>

                      {code}

                       

                      to the modeshape-distribution project's pom.xml file and now the xmlbeans is included in the tika module.

                       

                      Should this dependency be there for the assembly to work?

                       

                       

                      {noformat}

                      % unzip -l ~/.m2/repository/org/modeshape/modeshape-distribution/3.2-SNAPSHOT/modeshape-distribution-3.2-SNAPSHOT-jbosseap-61-dist.zip | grep modules/org/apache/tika/1.3 | sort -k 4

                              0  03-25-13 18:18   modules/org/apache/tika/1.3/

                          95536  11-19-12 14:46   modules/org/apache/tika/1.3/apache-mime4j-core-0.7.2.jar

                         304810  11-19-12 14:46   modules/org/apache/tika/1.3/apache-mime4j-dom-0.7.2.jar

                          43033  11-21-12 15:32   modules/org/apache/tika/1.3/asm-3.1.jar

                          73098  11-19-12 13:55   modules/org/apache/tika/1.3/commons-codec-1.5.jar

                         241367  11-19-12 12:07   modules/org/apache/tika/1.3/commons-compress-1.4.1.jar

                          60686  11-22-12 09:31   modules/org/apache/tika/1.3/commons-logging-1.1.1.jar

                         313898  11-19-12 12:07   modules/org/apache/tika/1.3/dom4j-1.6.1.jar

                         188471  03-21-13 11:51   modules/org/apache/tika/1.3/fontbox-1.7.1.jar

                          28804  11-22-12 12:43   modules/org/apache/tika/1.3/geronimo-stax-api_1.0_spec-1.0.1.jar

                         521237  11-22-12 12:43   modules/org/apache/tika/1.3/isoparser-1.0-RC-1.jar

                         614203  11-22-12 09:49   modules/org/apache/tika/1.3/javassist-3.11.0.GA.jar

                          50942  03-21-13 11:51   modules/org/apache/tika/1.3/jempbox-1.7.1.jar

                         220813  11-22-12 12:43   modules/org/apache/tika/1.3/juniversalchardet-1.0.3.jar

                           3070  03-25-13 18:18   modules/org/apache/tika/1.3/module.xml

                        3910899  03-21-13 11:51   modules/org/apache/tika/1.3/pdfbox-1.7.1.jar

                        1820323  11-19-12 12:07   modules/org/apache/tika/1.3/poi-3.8.jar

                         933010  11-19-12 12:07   modules/org/apache/tika/1.3/poi-ooxml-3.8.jar

                        4706775  11-19-12 12:07   modules/org/apache/tika/1.3/poi-ooxml-schemas-3.8.jar

                        1186887  11-19-12 12:07   modules/org/apache/tika/1.3/poi-scratchpad-3.8.jar

                          90722  11-22-12 12:43   modules/org/apache/tika/1.3/tagsoup-1.2.1.jar

                         475853  03-21-13 11:49   modules/org/apache/tika/1.3/tika-core-1.3.jar

                         486107  03-21-13 11:49   modules/org/apache/tika/1.3/tika-parsers-1.3.jar

                          30301  11-19-12 12:07   modules/org/apache/tika/1.3/vorbis-java-core-0.1-tests.jar

                          47478  11-19-12 12:07   modules/org/apache/tika/1.3/vorbis-java-core-0.1.jar

                          14752  11-19-12 12:07   modules/org/apache/tika/1.3/vorbis-java-tika-0.1.jar

                        2666695  03-25-13 18:11   modules/org/apache/tika/1.3/xmlbeans-2.3.0.jar

                          94672  11-19-12 12:07   modules/org/apache/tika/1.3/xz-1.0.jar

                      {noformat}

                      • 8. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
                        Horia Chiorean Master

                        No, not really. ModeShape does not directly depend on xmlbeans. It is a transitive Tika dependency. modeshape-distribution should contain only the ModeShape-produced artifacts.

                         

                        The fact that you don't have a xmlbeans-2.3.0.pom in your local repository, indicates that it was never retrieved properly.

                         

                        This is the partial output of the mvn dependency:tree command for the modeshape-extractor-tika module:

                         

                        org.modeshape:modeshape-extractor-tika:jar:3.2-SNAPSHOT

                        +- org.apache.tika:tika-parsers:jar:1.3:compile

                        |  +- org.apache.tika:tika-core:jar:1.3:compile

                        |  +- org.gagravarr:vorbis-java-tika:jar:0.1:compile

                        |  |  \- org.gagravarr:vorbis-java-core:jar:tests:0.1:runtime

                        |  +- org.apache.james:apache-mime4j-core:jar:0.7.2:compile

                        |  +- org.apache.james:apache-mime4j-dom:jar:0.7.2:compile

                        |  +- org.apache.commons:commons-compress:jar:1.4.1:compile

                        |  |  \- org.tukaani:xz:jar:1.0:compile

                        |  +- commons-codec:commons-codec:jar:1.5:compile

                        |  +- org.apache.pdfbox:pdfbox:jar:1.7.1:compile

                        |  |  +- org.apache.pdfbox:fontbox:jar:1.7.1:compile

                        |  |  +- org.apache.pdfbox:jempbox:jar:1.7.1:compile

                        |  |  \- commons-logging:commons-logging:jar:1.1.1:compile

                        |  +- org.apache.poi:poi:jar:3.8:compile

                        |  +- org.apache.poi:poi-scratchpad:jar:3.8:compile

                        |  +- org.apache.poi:poi-ooxml:jar:3.8:compile

                        |  |  +- org.apache.poi:poi-ooxml-schemas:jar:3.8:compile

                        |  |  |  \- org.apache.xmlbeans:xmlbeans:jar:2.3.0:compile

                         

                        As you see, it's a 3rd degree transitive dependency, with a "compile" scope. I don't understand why it's not being resolved for you locally.

                         

                        You can try to remove from your local repository all the graph of dependencies up-to & including xml beans: tika-parsers, poi-ooxml, etc and force Maven to re-retrieve those artifacts.

                        1 of 1 people found this helpful
                        • 9. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
                          Horia Chiorean Master

                          The xml beans artifact is brought in the AS7 kit via a Maven assembly descriptor which looks like this: https://github.com/ModeShape/modeshape/blob/master/modeshape-assembly-descriptors/src/main/resources/assemblies/jbosseap-61-dist.xml#L127

                          Maven's transitive dependency resolution mechanism should resolve & bring in the xmlbeans.jar.

                           

                          With the exception of the above descriptor, ModeShape does not and should not refer to xml beans in any other way.

                          • 10. Re: 3.1 SNAPSHOT and JBoss AS7 kit issue
                            Brian Wallis Master

                            Curious, if I run the dependency tree I don't get a reference to xmlbeans.

                             

                            {noformat}

                            [INFO] --- maven-dependency-plugin:2.3:tree (default-cli) @ modeshape-extractor-tika ---

                            [INFO] org.modeshape:modeshape-extractor-tika:jar:3.2-SNAPSHOT

                            [INFO] +- org.apache.tika:tika-parsers:jar:1.3:compile

                            [INFO] |  +- org.apache.tika:tika-core:jar:1.3:compile

                            [INFO] |  +- org.gagravarr:vorbis-java-tika:jar:0.1:compile

                            [INFO] |  |  \- org.gagravarr:vorbis-java-core:jar:tests:0.1:runtime

                            [INFO] |  +- org.apache.james:apache-mime4j-core:jar:0.7.2:compile

                            [INFO] |  +- org.apache.james:apache-mime4j-dom:jar:0.7.2:compile

                            [INFO] |  +- org.apache.commons:commons-compress:jar:1.4.1:compile

                            [INFO] |  |  \- org.tukaani:xz:jar:1.0:compile

                            [INFO] |  +- commons-codec:commons-codec:jar:1.5:compile

                            [INFO] |  +- org.apache.pdfbox:pdfbox:jar:1.7.1:compile

                            [INFO] |  |  +- org.apache.pdfbox:fontbox:jar:1.7.1:compile

                            [INFO] |  |  +- org.apache.pdfbox:jempbox:jar:1.7.1:compile

                            [INFO] |  |  \- commons-logging:commons-logging:jar:1.1.1:compile

                            [INFO] |  +- org.apache.poi:poi:jar:3.8:compile

                            [INFO] |  +- org.apache.poi:poi-scratchpad:jar:3.8:compile

                            [INFO] |  +- org.apache.poi:poi-ooxml:jar:3.8:compile

                            [INFO] |  |  +- org.apache.poi:poi-ooxml-schemas:jar:3.8:compile

                            [INFO] |  |  \- dom4j:dom4j:jar:1.6.1:compile

                            {noformat}

                             

                            I had a look at the pom for poi-ooxml-schemas and it had a local (artifactory) repository generated pom instead of the real one so it has no dependencies.

                             

                            I just removed the entry for poi-ooxml-schemas from my local repo and from my local repository cache and let it re-download from the eternal repository and all is now well. The distribution has got the xmlbeans jar in it at last!.

                             

                            Makes me a little bit concerned about my local repository cache. Might have to have a bit of a spring cleanout (although it is autumn here :-)

                             

                            Thanks for the dependency listing from mvn, it pointed me to the real problem.