8 Replies Latest reply on Dec 6, 2002 6:00 PM by Alp

    entity bean is not consistent with database.

    Alp Newbie

      Hi,

      I have more than 15 entity beans and almost 300 junit test cases to test the business logic. Everything had seemed fine until I wanted to run multi-threaded tests against the application to see how it performs. It sucked! The problem was I didn't marked getter methods as read-only so concurrency didn't occur. Therefore, I marked all of my getter methods as read-only and all of my multi-threaded tests worked too. So far so good. However, when I tried my standard junit tests, I was surprised to see they were half broken..! There was no code change or whatsoever.

      I am using commit-option B. I also tried using C but it didn't help either.

      Does anyone know if there is a "tricky" setting that we should turn on/off when we use read-only methods ?

      Cheers,

      Alp

      PS: I am not talking about signing the whole entity bean as read only. I selectively set only getter methods as read-only.