2 Replies Latest reply on Jan 30, 2013 4:12 AM by swapna paleti

    JBOSS5.1 - Clustering issue in my app

    swapna paleti Newbie

      Hi,

       

        I've an issue with JBOSS(5.1) clustering. In my application 4 nodes supposed to be join in clustering but always one of the node is failing with following message ..

       

      Not sure why is it failing to join in clustering , but the node1 (10.0.21.1:55200) is up and running and clustered, any help on this is appreciated.

       

      2013-01-25 18:39:14,255 54711 INFO  [org.jboss.ha.framework.interfaces.HAPartition.BNW_PROD_CONTROLLER] (JBoss System Threads(1)-3:) Number of cluster members: 2

      2013-01-25 18:39:14,260 54716 INFO  [org.jboss.ha.framework.interfaces.HAPartition.BNW_PROD_CONTROLLER] (JBoss System Threads(1)-3:) Other members: 1

      2013-01-25 18:39:18,688 59144 WARN  [org.jgroups.protocols.pbcast.GMS] (main:) join(10.0.21.4:55200) sent to 10.0.21.1:55200 timed out (after 3000 ms), retrying

      2013-01-25 18:39:53,719 94175 WARN  [org.jgroups.protocols.pbcast.GMS] (main:) join(10.0.21.4:55200) sent to 10.0.21.1:55200 timed out (after 3000 ms), retrying

      2013-01-25 18:39:58,724 99180 WARN  [org.jgroups.protocols.pbcast.GMS] (main:) join(10.0.21.4:55200) sent to 10.0.21.1:55200 timed out (after 3000 ms), retrying

       

       

      Thanks

      Swapna Paleti

        • 1. Re: JBOSS5.1 - Clustering issue in my app
          Radoslav Husar Master

          It is suspicious that other nodes are joining the cluster fine except for one node. I would double-check the node system configuration, network/routing, firewall configuration, etc. Or is that failing node different every time?

          • 2. Re: JBOSS5.1 - Clustering issue in my app
            swapna paleti Newbie

            As per the log, Node4 trying to join with Node1

             

            In Node4 we are seeing following retry failures infinitely

             

            2013-01-25 18:39:18,688 59144 WARN  [org.jgroups.protocols.pbcast.GMS] (main:) join(10.0.215.4:55200) sent to 10.0.215.1:55200 timed out (after 3000 ms), retrying

             

            at the same time in Node1 flush got failed

             

            2013-01-25 18:46:58,479 905434 WARN  [org.jgroups.protocols.pbcast.GMS] (ViewHandler,BNW_PROD_CONTROLLER-HAPartitionCache,10.0.215.1:55200:) GMS flush by coordinator at 10.0.215.1:55200 failed

             

            The current JBOSS version we are using is JBOSS-5.1.1

             

            It seems that this issue related to JIRA TICKET-

             

            Thanks in advance.