0 Replies Latest reply on Feb 12, 2013 10:41 AM by Stefan Dickel

    JBoss AS 6 with dedicated management address

    Stefan Dickel Newbie

      Hi to everyone.

       

      I run a JBoss AS 6 cluster on a AIX 7 server which is in the application layer of a 3 tier architecture. The server has two seperate NIC in different networks with out any routing between them.

      NIC one is for the frontend and bound to 192.168.1.1 while NIC two is for management access and should be bound to 192.168.2.2.

      To monitor the JBoss AS with VirtualVM or JConsole i need to bind the RMI/JMX ports to NIC 2.

       

      After searching two days long in the web I didn't find any documentation nor hints how to do that. The only vague hint was to set a bind address for management.

       

      So I tried to set the commandline parameter -Djboss.bind.address.management=192.168.2.2 and modified the file

      /usr/jboss6/jboss-6.1.0/server/om_cluster/conf/bindingservice.beans/META-INF/bindings-jboss-beans.xml where i have insertet the two highlightet lines.

       

      <bean class="org.jboss.services.binding.ServiceBindingMetadata">

        <property name="serviceName">jboss.remoting:service=JMXConnectorServer,protocol=rmi</property>

        <property name="port">1090</property>

        <property name="hostName">${jboss.bind.address.management}</property>

        <property name="description">RMI/JRMP socket for connecting to the JMX MBeanServer</property>

      </bean>

       

      <bean class="org.jboss.services.binding.ServiceBindingMetadata">

        <property name="serviceName">jboss.remoting:service=JMXConnectorServer,protocol=rmiServer</property>

        <property name="port">1091</property>

        <property name="hostName">${jboss.bind.address.management}</property>

        <property name="description">RMI server socket</property>

      </bean>

       

      A netstat -a on the server tells that the two ports 1090 and 1091 are bound to the correct ip-address. But if i try to make a remote connection with jconsole from a machine in the same network I get a time out.

       

      Has anyone done such a configuration bevore or any good idea what could be wrong in my configuration?

      Are there more things to adopt in the configuration to get this to work?

       

      Any help would be appreciated.

      Thanks

      Stefan