1 Reply Latest reply on Feb 13, 2013 1:36 PM by Snjezana Peco

    Cannot install JBoss Tools Core 4.1.0.Alpha1 (bits for QE testing)

    Juergen Zimmermann Master

      I tried to install JBoss Tools Core 4.1.0.Alpha1 as mentioned at http://lists.jboss.org/pipermail/jbosstools-dev/2013-February/006973.html. I used a fresh Eclipse installation from http://www.eclipse.org/downloads/index-developer.php?release=juno for "Eclipse IDE for Java EE Developers (Juno SR2 RC3)". However, I'm getting the following stacktrace during installation. org.eclipse.ant.core 3.2.401.v20121204-162022 is part of the Eclipse Java EE distribution.

       

      Cannot complete the install because of a conflicting dependency.

        Software being installed: JBoss Maven Hibernate Configurator 1.5.0.Alpha1-v20130208-1533-B2 (org.jboss.tools.maven.hibernate.feature.feature.group 1.5.0.Alpha1-v20130208-1533-B2)

        Software currently installed: Eclipse IDE for Java EE Developers 1.5.2.20130205-2019 (epp.package.jee 1.5.2.20130205-2019)

        Only one of the following can be installed at once:

          Ant Build Tool Core 3.2.500.v20121231-155506 (org.eclipse.ant.core 3.2.500.v20121231-155506)

          Ant Build Tool Core 3.2.401.v20121204-162022 (org.eclipse.ant.core 3.2.401.v20121204-162022)

        Cannot satisfy dependency:

          From: Eclipse IDE for Java EE Developers 1.5.2.20130205-2019 (epp.package.jee 1.5.2.20130205-2019)

          To: org.eclipse.epp.package.jee.feature.feature.group [1.5.2.20130205-2019]

        Cannot satisfy dependency:

          From: Java EE IDE Feature 1.5.2.20130205-2019 (org.eclipse.epp.package.jee.feature.feature.group 1.5.2.20130205-2019)

          To: org.eclipse.platform.feature.group [4.2.1.v20130118-173121-9MF7GHYdG0B5kx4EZVhfXV--sFmQ9QiOL5DboE]

        Cannot satisfy dependency:

          From: Eclipse Platform 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4EZVhfXV--sFmQ9QiOL5DboE (org.eclipse.platform.feature.group 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4EZVhfXV--sFmQ9QiOL5DboE)

          To: org.eclipse.ant.core [3.2.401.v20121204-162022]

        Cannot satisfy dependency:

          From: Hibernate Console 3.7.0.Alpha1-v20130210-1655-B6 (org.hibernate.eclipse.console 3.7.0.Alpha1-v20130210-1655-B6)

          To: bundle org.eclipse.ant.core 3.2.500

        Cannot satisfy dependency:

          From: JBoss Maven Hibernate Configurator 1.5.0.Alpha1-v20130208-1533-B2 (org.jboss.tools.maven.hibernate 1.5.0.Alpha1-v20130208-1533-B2)

          To: bundle org.hibernate.eclipse.console 0.0.0

        Cannot satisfy dependency:

          From: JBoss Maven Hibernate Configurator 1.5.0.Alpha1-v20130208-1533-B2 (org.jboss.tools.maven.hibernate.feature.feature.group 1.5.0.Alpha1-v20130208-1533-B2)

          To: org.jboss.tools.maven.hibernate [1.5.0.Alpha1-v20130208-1533-B2]