8 Replies Latest reply on Sep 30, 2013 5:24 AM by Hemant Gupta

    rich:dataScroller is broken in 4.3.0.Final

    robert walker Newbie

      Hi rf team, i believe the rich:dataScroller is broken in 4.3.0.Final

       

      I saw the other post about this (https://community.jboss.org/thread/165196?tstart=0)  but

      i think it is thought to be resolved? 

       

       

      {code}

      <h:form>

                       <rich:dataScroller for="tableId" />

       

                      <rich:dataTable id="tableId"

                                      value="#{orderBean.orderList}"

                                      var="o"

                                      rows="5">

       

                          <h:column>

                              <f:facet name="header">Order No</f:facet>                   

                              #{o.orderNo}

                          </h:column>

                </rich:dataTable>

      </h:form>

      {code}

       

      if i use 4.2.3.Final, the scolling works, then I switch my pom to 4.3.0.Final and scrolling stops working, no

      errors from server, it just seems to ignore the click for next page. i can attach my simple 4-5 file test app if needed

       

       

      thanks RF team, we really like RF here at verizon wireless

        • 1. Re: rich:dataScroller is broken in 4.3.0.Final
          Juraj Húska Master

          Hi Robert,

           

          it is weird. The dataScroller works for example in this example:

          http://showcase.richfaces.org/richfaces/component-sample.jsf?demo=dataScroller&skin=blueSky

           

          Have you tried to delete the browser cache ?

          • 2. Re: rich:dataScroller is broken in 4.3.0.Final
            robert walker Newbie

            thanks for the suggestion, i do think something is wrong though, from other posts also in the other thread seem agree.

            i ran the app the first time, had never been run b4 so cahce was not an issue, and it is not working, something is not right, i went back

            to 4.2.3.Final and it is working great, but i would like to use some of the new 4.3.0 features. i added a sample app to the original post

            • 3. Re: rich:dataScroller is broken in 4.3.0.Final
              Michal Petrov Master

              Hi,

               

              you seem to be using an old version of Guava which is causing the issue.

               

              If you remove

              <dependency>
                  <groupId>com.google.guava</groupId>
                  <artifactId>guava</artifactId>
                  <version>r09</version>
              </dependency>
              

              from the POM in your example it will work.

              1 of 1 people found this helpful
              • 4. Re: rich:dataScroller is broken in 4.3.0.Final
                Juraj Húska Master

                I have tried to run your project. I had the problems you talked about. I managed to fix it.

                 

                There are some wrong dependencies in the pom.xml.

                 

                Firstly it does not work because of the wrong guava dependency version. Let richfaces-bom define the version for you, so delete the <version>r09</version>. I deployed it on JBoss AS 7.1.1.Final.

                By this I managed to run the project with working dataScroller.

                 

                I am also not sure why you need:

                <dependency>

                            <groupId>org.richfaces.cdk</groupId>

                            <artifactId>annotations</artifactId>

                            <version>4.1.0-SNAPSHOT</version>

                            <scope>provided</scope>

                        </dependency>

                 

                But it should work with it.

                 

                Did you suceed to run it ?

                • 5. Re: rich:dataScroller is broken in 4.3.0.Final
                  robert walker Newbie

                  thank you michal and Juraj, if i remove the entire dependeny tag structure for guava, i get maven warnings

                   

                  [WARNING] Invalid POM for com.google.guava:guava:jar:11.0.2, transitive dependencies (if any) will not be available, enable debug logging for more details

                   

                   

                  but just removing <version>r09</version> seems to have fixed it, thanks so much guys, i appreciate it and

                  can't wait to use RF 4.3.0.Final in production. You both had correct answers but could only mark one as correct and the other helpful

                   


                   



                  • 6. Re: rich:dataScroller is broken in 4.3.0.Final
                    Paul Baker Apprentice

                    I don't think that you should incl guava...

                    Here is a sample of a pom from a simple Richfaces project using 4.3.0 running on JBoss..

                    BRgds/Paul

                     

                     

                    <properties>
                        <org.richfaces.bom.version>4.3.0.Final</org.richfaces.bom.version>
                    </properties>
                     ...
                     ...
                     <dependencyManagement>
                      <dependencies>
                       <dependency>
                        <groupId>org.richfaces</groupId>
                        <artifactId>richfaces-bom</artifactId>
                        <version>${org.richfaces.bom.version}</version>
                        <scope>import</scope>
                        <type>pom</type>
                       </dependency>
                      </dependencies>
                     </dependencyManagement>
                     ...
                     ...
                     <dependencies>
                      <dependency>
                       <groupId>org.richfaces.ui</groupId>
                       <artifactId>richfaces-components-ui</artifactId>
                      </dependency>
                      <dependency>
                       <groupId>org.richfaces.core</groupId>
                       <artifactId>richfaces-core-impl</artifactId>
                      </dependency>
                      
                      <dependency>
                       <groupId>org.jboss.spec.javax.faces</groupId>
                       <artifactId>jboss-jsf-api_2.1_spec</artifactId>
                       <version>2.0.0.Beta1</version>
                       <type>jar</type>
                       <scope>provided</scope>
                      </dependency>
                      
                     </dependencies>
                    
                    
                    • 7. Re: rich:dataScroller is broken in 4.3.0.Final
                      robert walker Newbie

                      if i comment it out, it does indeed run on jboss 7.x but according to   https://community.jboss.org/wiki/HowToAddRichFaces4xToProjectsNotBasedOnMaven

                      it states

                      "Also RichFaces 4.x make use of the google-guava-r08 which is a core runtime dependency."

                      • 8. Re: rich:dataScroller is broken in 4.3.0.Final
                        Hemant Gupta Newbie

                        Hi,

                         

                        I am facing a similar issue and using Richfaces 4.3.0 Final version. Earlier, I was using RichFaces 4.2.1 and datascroller was working fine, but with new 4.3.0 version, it is no longer working. When I click on page 2, nothing happens; as if the request never went through. Also, I don't see any javascript error.

                         

                        JSF code snippet:

                         

                                                    <h:form id="form">
                                                        <h:panelGroup id="Data1">
                                                            <rich:column width="85%" style="vertical-align:top; padding:0;">
                                                                <rich:dataTable value="#{data}" var="d" id="xdata" rows="5" >                                       
                                                                <rich:column width="10%" style="vertical-align:top">
                                                                    <f:facet name="header">
                                                                        <h:outputText value="Label" />
                                                                    </f:facet>
                                                                    <h:outputText value="#{d.value}"/>
                                                                </rich:column>

                                                            </rich:dataTable>
                                                            <rich:dataScroller for="xdata" renderIfSinglePage="false"/>
                                                            </rich:column>
                                                        </h:panelGroup>
                                                    </h:form>

                         

                         

                        Richfaces : 4.3.0 Final

                        Maven: NOT using maven

                        Guava: using Guava 15.0 version. even tried with Guava 13.0.1, but no success

                         

                        kindly help me with this issue...

                         

                        Thanks

                        Hemant