1 Reply Latest reply on Feb 25, 2013 3:59 AM by Nicklas Karlsson

    403 Access denied on Jboss 7.1.1 with RestServices

    malcomtom Newbie

      Dear community,

       

      I am using Jboss 7.1.1 with with a Seam 2.2 based application. Everything works well and i am able to login and acces the webpages of my application.

      The problem happens when i try to access any Restservice of this application (Resteasy based). Then i get an 403 error:

       

      HTTP Status 403 - Access to the requested resource has been denied


      type Status report

      message Access to the requested resource has been denied

      description Access to the specified resource (Access to the requested resource has been denied) has been forbidden.


      JBoss Web/7.0.13.Final

       

      I tried to increase the loglevel, bot nothing was logged on console/server.log and therefore i am not able to show you some more detailed information.

      It all worked well on Jboss 4.2.3 - maybe i do have some misconfiguration of my Jboss?

      Is there anything i have to take into account for configuring Restservices (especial security parts)?

      For authentication and authorization, the webservices are using the security mechanism of the application (based on Shiro)

      and to the container one (e.g. Jboss security,...)

       

      Thankx very much in advance for your help :-)

       

      best regards

       

      Malcom