4 Replies Latest reply on Jun 16, 2015 8:43 AM by Adam A R

    Migrating a SAR file from 4.2.2 to 7.1.1

    Joe Nelson Newbie

      I'm trying to migrate a SAR file from our JBoss 4.2.2 to JBoss version 7.1.1. When I try to load the SAR, JBoss just seems to hang. I've turned on TRACE and can see nothing obvious to me.

       

       

      my jboss-service.xml file looks like:

       

      {code:xml}

      <?xml version="1.0" encoding="UTF-8"?>

      <server xmlns="urn:jboss:service:7.0"

          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

          xsi:schemaLocation="urn:jboss:service:7.0 jboss-service_7_0.xsd">

       

          <mbean code="com.mt.ecom.integration.batch.mbean.elead.LeadProcessorImpl" name="com.mt:service=LeadProcessor">

              <attribute name="jobId">leadProcessor</attribute>

              <attribute name="group">elead</attribute>

              <attribute name="name">leadProcessor</attribute>

              <attribute name="JndiName">java:jboss/LeadProcessor</attribute>

              <depends>jboss.jca:name=java:jboss/mt/datasource/vi,service=DataSourceBinding</depends>

          </mbean>

      </server>

      {code:xml}

      my jboss-deployment-structure lists all the resource.

       

      my service implements start, stop, create and destroy methods...

       

      Internal t the service, its setting up quartz cron jobs to periodically process database records. But as I can't see the job even try to start (as evidenced by a lack of debug in the log), I don't think the quartz implementation has anything to do with the problem (yet).

       

      Any direction would be appreciated.