2 Replies Latest reply on Mar 4, 2013 10:41 AM by Daniel Redondo

    SSL connection started at a wrong port (jboss 5.1.0.GA)

    Daniel Redondo Newbie

      Hello, I'm configuring jboss 5.1.0.GA to get a SSL connection.

       

      My only two connectors at server.xml are:

       

           <!-- A AJP 1.3 Connector on port 8009 -->

            <Connector protocol="AJP/1.3" port="8009" address="${jboss.bind.address}"

               redirectPort="8443" />

       

            <!-- SSL/TLS Connector configuration using the admin devl guide keystore -->

            <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"

                 maxThreads="150" scheme="https" secure="true"

                 clientAuth="true" sslProtocol="TLS" address="${jboss.bind.address}"

                 connectionTimeout="60000"

                 keystoreFile="${jboss.server.home.dir}/certificates/server.p12"

                 keystoreType="PKCS12" keystorePass="psswrd4kEy"

                 truststoreFile="${jboss.server.home.dir}/certificates/truststore.jks"

                 truststorePass="psswrd4sTr"

                 truststoreType="JKS"/>

       

      But when I start jboss, I get the SSL conection at the 8371 port, the specific message at the start if this conection is:

       

      INFO  [AjpProtocol] Starting Coyote AJP/1.3 at ajp-127.0.0.1-7937

      INFO  [Http11Protocol] Starting Coyote HTTP/1.1 at port http-127.0.0.1-8371

       

      So, my question is why it is starting at 8371, if I am specifying the port number 8443.

       

      Thank you in advance, regards, Daniel.