3 Replies Latest reply on Jan 30, 2009 10:29 AM by Thomas Parle

    JBoss Rules/Drools JBoss AS 5 support

    Thomas Parle Newbie

      Hi,

      I did not find any clear information yet: when JBoss Rules will officially support JBoss AS 5 ?

      Thank you

        • 2. Re: JBoss Rules/Drools JBoss AS 5 support
          Burr Sutter Master

          Your question is a little bit confusing. Are you asking when Drools 5 Guvnor (drools-guvnor.war) will run on AS5?

          AS5 is not an officially supported enterprise solution by JBoss at this time. It is still undergoing extensive QA efforts leading to an eventual product release.

          With that said, I've noticed some issues when deploying the community version of Drools Guvnor (the web UI & repository) to the community version of the application server.

          Error messages:

          18:35:48,329 INFO [PersistenceUnitDeployment] Starting persistence unit persis
          ence.unit:unitName=#ACL
          18:35:48,342 ERROR [AbstractKernelController] Error installing to Start: name=p
          rsistence.unit:unitName=#ACL state=Create
          java.lang.RuntimeException: Specification violation [EJB3 JPA 6.2.1.2] - You ha
          e not defined a non-jta-data-source for a RESOURCE_LOCAL enabled persistence co
          text named: ACL
          
          and
          
          18:36:00,264 ERROR [AbstractKernelController] Error installing to Configured: na
          me=jboss.web.deployment:war=/drools-guvnor state=Instantiated mode=Manual requir
          edState=Configured
          java.lang.RuntimeException: Exception setting attribute SecurityManagement on mb
          ean jboss.web.deployment:war=/drools-guvnor
           at org.jboss.system.ServiceConfigurator.configure(ServiceConfigurator.ja
          va:170)
          


          • 3. Re: JBoss Rules/Drools JBoss AS 5 support
            Thomas Parle Newbie

            Thank you for your answer.
            Some customers of ours will soon use JBoss AS 5 for development, and I wanted to know what version of Drools would be appropriate for them to use, since I saw some users like you experimenting deployment issues with Drools 4. What about Drools 5 current milestone ?