3 Replies Latest reply on Mar 7, 2013 1:16 AM by Daniel Bevenius

    Aerogear Controller Demo Class Not Found

    iampowers Newbie

      I'm attempting to run the aero-controller-demo and running into the following error:

       

      09:41:00,681 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/aerogear-controller-demo]] (MSC service thread 1-3) Exception starting filter StrictTransportFilter: java.lang.ClassNotFoundException: org.jboss.aerogear.security.filter.StrictTransportFilter from [Module "deployment.aerogear-controller-demo.war:main" from Service Module Loader]

                at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)

                at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)

                at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)

                at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)

                at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)

                at org.jboss.as.web.deployment.WebInjectionContainer.newInstance(WebInjectionContainer.java:72) [jboss-as-web-7.1.1.Final.jar:7.1.1.Final]

                at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:441) [jbossweb-7.0.13.Final.jar:]

                at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3269) [jbossweb-7.0.13.Final.jar:]

                at org.apache.catalina.core.StandardContext.start(StandardContext.java:3865) [jbossweb-7.0.13.Final.jar:]

                at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)

                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) [rt.jar:1.6.0_27]

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [rt.jar:1.6.0_27]

                at java.lang.Thread.run(Unknown Source) [rt.jar:1.6.0_27]

       

      I cloned the GIT repository and imported the project into Eclipse (Juno). I also enabled the JBoss repositories to resolve the missing maven dependencies. I'm attempting to run it on a local JBoss AS 7.1.1 server.

       

      Am I missed a dependency of some sort?

       

      Thanks,

      Nick

        • 1. Re: Aerogear Controller Demo Class Not Found
          Daniel Bevenius Master

          Hi Nick,

           

          sorry about that. We are about to release a new version of AeroGear but have not uploaded all dependencies to the central maven repository as of yet. We still have some testing of the dependant projects with are underway at the moment.

           

          If you like to try it out straight away can clone and bulid the two projects below:

           

          git@github.com:aerogear/aerogear-security.git
          git@github.com:aerogear/aerogear-security-picketlink.git
          

           

          If that does not work you can comment out the following section from 'src/main/webapp/WEB-INF/web.xml:

           

           <filter>
                  <filter-name>StrictTransportFilter</filter-name>
                  <filter-class>org.jboss.aerogear.security.filter.StrictTransportFilter</filter-class>
                  <init-param>
                      <param-name>max-age</param-name>
                      <param-value>2592000</param-value>
                  </init-param>
                  <init-param>
                      <param-name>include-subdomains</param-name>
                      <param-value>false</param-value>
                  </init-param>
                  <init-param>
                      <param-name>location</param-name>
                      <param-value>https://localhost:8443/aerogear-controller-demo/mycars</param-value>
                  </init-param>
              </filter>
              <filter-mapping>
                  <filter-name>StrictTransportFilter</filter-name>
                  <url-pattern>/mycars</url-pattern>
              </filter-mapping>
          
          

           

           

          This will all be sorted out soon, and I'll post back to this thread to let you know.

           

          Regards,

           

          /Dan

          • 2. Re: Aerogear Controller Demo Class Not Found
            iampowers Newbie

            I appreciate your quick response. I was unable to clone the GIT repositories (access was denied, I think there is a security joke there) so I commented out the filter and got it to work. Thanks also for the offer to post back when it's all sorted out.

             

            Thanks,

            Nick

            • 3. Re: Aerogear Controller Demo Class Not Found
              Daniel Bevenius Master

              Hi,

               

              the original issue with building should now been sorted out as the correct artifacts are now in maven central.

              Let us know if you have any issues.

               

              Thanks,

               

              /Dan