0 Replies Latest reply on Mar 4, 2013 5:03 AM by ribiggy

    Richfaces 4.0.0 a4j:push not working

    ribiggy Newbie

      I'm testing a4j:push on Richfaces 4.0.0.final (can't use other version) and I can't get it to work. I'm getting IllegalArgumentException

       

      11:09:06,829 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/test].[Faces Servlet]] (http-localhost-127.0.0.1-8443-2) Servlet.service() for servlet Faces Servlet threw exception: java.lang.IllegalArgumentException
      at org.richfaces.resource.PushResource.encode(PushResource.java:87) [richfaces-components-ui-4.0.0.Final.jar:4.0.0.Final]
      at org.richfaces.resource.UserResourceWrapperImpl.encode(UserResourceWrapperImpl.java:193) [richfaces-core-impl-4.0.0.Final.jar:4.0.0.Final]
      at org.richfaces.resource.ResourceHandlerImpl.handleResourceRequest(ResourceHandlerImpl.java:226) [richfaces-core-impl-4.0.0.Final.jar:4.0.0.Final]
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:591) [jboss-jsf-api_2.1_spec-2.0.1.Final.jar:2.0.1.Final]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:329) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:248) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:275) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:161) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:489) [jbossweb-7.0.13.Final.jar:]
      at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.1.1.Final.jar:7.1.1.Final]
      at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:153) [jboss-as-web-7.1.1.Final.jar:7.1.1.Final]
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:155) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:368) [jbossweb-7.0.13.Final.jar:]
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:877) [jbossweb-7.0.13.Final.jar:]
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:671) [jbossweb-7.0.13.Final.jar:]
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:930) [jbossweb-7.0.13.Final.jar:]
      at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_03]
      
      

       

      I checked the source code and it seems like my topic defined in standalone.xml and listener is not found in RequestParameterValuesMap and thats why it throws exception. But I don't know what else i need to configure to make it work.

       

      I'm using:

       

      JBoss 7.1.1.FINAL

      Richfaces 4.0.0.Final

      Servlet 3.0

      jboss-jsf-api_2.1_spec-2.0.1.Final

      jsf-impl-2.1.7-jbossorg-2

       

      More information about configuration i did so far: http://stackoverflow.com/questions/15135651/richfaces-4-0-0-a4jpush-not-working