2 Replies Latest reply on Mar 7, 2013 6:37 AM by chandramoulee mukherjee

    Getting deployment error in JBOSS 6.0 -could not be found in the Ejb3Registrar

    chandramoulee mukherjee Newbie

      Hi,

           I' m new in Jboss. I'm trying to create a JPA project using -

      1. Jboss 6.0

      2. Eclipse Helios

      3. Oracle 10g Database.

       

      I have created a Oracle local transaction Datasource and used that in my persistence.xml. Here is my persistence.xml -

      <?xml version="1.0" encoding="UTF-8"?>

      <persistence version="2.0" xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_2_0.xsd">

          <persistence-unit name="order" transaction-type="JTA">

          <provider>org.hibernate.ejb.HibernatePersistence</provider>

              <jta-data-source>java:/RDMS</jta-data-source>

              <class>com.order.ejb.jpa.LineItem</class>

              <class>com.order.ejb.jpa.Order</class>

              <class>com.order.ejb.jpa.Part</class>

              <class>com.order.ejb.jpa.Vendor</class>

              <class>com.order.ejb.jpa.VendorPart</class>

              <shared-cache-mode>NONE</shared-cache-mode>

              <properties>

                  <property name="hibernate.dialect" value="org.hibernate.dialect.Oracle10gDialect" />

                  <property name="hibernate.transaction.manager_lookup_class"

                      value="org.hibernate.transaction.JBossTransactionManagerLookup" />

                  <property name="hibernate.show_sql" value="true"/>

                    <property name="hibernate.format_sql" value="true"/>

                    <property name="hibernate.query.factory_class" value="org.hibernate.hql.classic.ClassicQueryTranslatorFactory"/>

              </properties>

           </persistence-unit>

      </persistence>

       

      The DS looks to be created successfully. It returns successful Connection on testing. However, when I deploying my project [Order.jar], it is fiving me below error -

       

      Failed to create Resource Order.jar - cause: java.lang.Exception:Failed to start deployment [vfszip:/D:/Jboss/jboss-6.0.0.M1/server/default/deploy/Order.jar/] during deployment of 'Order.jar' - cause: java.lang.RuntimeException:org.jboss.deployers.client.spi.IncompleteDeploymentException: 

      Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES:

      Deployment "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3_endpoint" is missing the following dependencies:

      Dependency "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3" (should be in state "Installed", but is actually in state "**ERROR**") DEPLOYMENTS IN ERROR: Deployment "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3" is in error due to the following reason(s):

      **ERROR**, java.lang.RuntimeException: StatefulSessionProxyFactory org.jboss.ejb3.proxy.impl.factory.session.stateful.StatefulSessionRemoteProxyFactory@32f62c has defined container name "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3", but this could not be found in the Ejb3Registrar -> org.jboss.deployers.client.spi.IncompleteDeploymentException:Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES: Deployment "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3_endpoint" is missing the following dependencies: Dependency "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3" (should be in state "Installed", but is actually in state "**ERROR**") DEPLOYMENTS IN ERROR: Deployment "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3" is in error due to the following reason(s): **ERROR**, java.lang.RuntimeException: StatefulSessionProxyFactory

      org.jboss.ejb3.proxy.impl.factory.session.stateful.StatefulSessionRemoteProxyFactory@32f62c has defined container name

       

      I'm attaching my Order.jar file in attachment. Can anyone please help me to sort out this deployment issue? I'm completely clueless here

       

      "jboss.j2ee:jar=Order.jar,name=RequestBean,service=EJB3", but this could not be found in the Ejb3Registrar