1 Reply Latest reply on May 7, 2013 3:51 AM by Ray He

    Guvnor 5.5.0 on Weblogic 10.3 - Deployment Exception

    Chris O'Grady Newbie

      Hi All,

       

      I’m trying to deploy guvnor-5.5.0 on Weblogic 10.3. I’m following the approach mentioned in the documentation of downloading the Tomcat war file and making any configuration changes, but I’m failing at the first hurdle.

       

      When I deploy the war file I get the following exception (Full error stack attached):

       

      "Exception 0 :

      org.jboss.weld.exceptions.DeploymentException: WELD-001408 Unsatisfied dependencies for type [RepositoryStartupService] with qualifiers [@Default] at injection point [[field] @Inject private org.drools.guvnor.server.repository.MailboxService.repositoryStartupService]"

       

      I was able to successfully deploy version 5.1.1, when there was just one war file, so I’m probably just missing some jars in the war or the server libs.

       

      I’m new to Drools/Guvnor and Weblogic, so would really appreciate some advice on how to fix this!

       

      Thanks in advance,

       

      Chris