2 Replies Latest reply on Mar 8, 2013 10:44 AM by Shobhit Tyagi

    JBPM 5.4 Installation Does not work

    Newbie

      Hi all after playing around with this software I am thoroughly unimpressed. My requirements are simple, get the basic jBPM 5 install up and running with drools-guvnor, jBPM console etc. working. Well for starters I had to hack the hell out of the build.xml to get everything installed. Then the ant start.demo also simply does not work. When you look in the deployments folder all you see are the failed deployments e.g. drools-guvnor.war.failed etc. I have used numerous tutrials and the jBPM Developer Guide Book, but still no joy.

       

      I have also bee trying to get a simple process flow working with jbds. The thing that concerns me most is the conflicting information out there. Some articles say you can only use 32 bit, others tell you that the required jboss tools will not work in jboss studio 6, the list goes on and on.

       

      I am trying to promote JBoss over the Oracle stack for a huge project, but if this is the state of the basic installs and tutorials where NOT ONE has worked correctly, I am more than a little hesitant.

       

      In less than no time I have managed to configure the full Oracle Fusion Middleware suite without hassles and the demos all work.

       

      Could somebody please point me in the direction of a relavent up to date tutorial for getting the jBPM suite installed with all the necessary plugins etc. ideally on JBoss DEV Studio 6 with EAP including the SOA platform. The server installs all work, but not once have I had success with the eclipse demo.

       

      Some advice would be greatly appreciated, I have been through dozens of tutorials and there are a lot of posts complaining about the same or very similar issues.

       

       

      All I am trying to do is model a very simple process in jBPM and integrate with JBoss ESB. Previous versions were a lot more stable and easy to use.

       

       

      I am running on Mac OS X, but will ultimately port to RH as the OS.

       

      Any help would be appreciated