0 Replies Latest reply on Mar 8, 2013 11:17 AM by Drew McLaughlin

    Problems Upgrading from RichFaces 4.2.0 to 4.3.1

    Drew McLaughlin Newbie

      Hi,

       

      I've just tried to upgrade my application from 4.2.0 to 4.3.a, as soon as I drop the new jars in I start running into compile errors.

       

      All I did was replace these jars:

       

      richfaces-components-api-4.2.0.Final.jar

      richfaces-components-ui-4.2.0.Final.jar

      richfaces-core-api-4.2.0.Final.jar

      richfaces-core-impl-4.2.0.Final.jar

       

      with these ones:

       

      richfaces-components-api-4.3.1.Final.jar

      richfaces-components-ui-4.3.1.Final.jar

      richfaces-core-api-4.3.1.Final.jar

      richfaces-core-impl-4.3.1.Final.jar

       

      But then many of my import statements recogninsing some fairly core classes. I can't find some fairl core classes, for example the following imports all fail.

       

      import org.richfaces.component.UICalendar;

      import org.richfaces.component.UIDataTable;

      import org.richfaces.component.UITabPanel;

      import org.richfaces.component.UIDataGrid;

       

      I've been googling for a bit but havn't managed to find a reason why simply changing the jars wouldnt work? Am a missing some other resourse that is now needed to run RichFaces? Any help you can give would be very much appreciated.

       

      Many thanks,

       

      ~Drew