5 Replies Latest reply on Mar 11, 2013 1:11 PM by Radoslav Husar

    config apache mod_cluster

    Nossair Faquihi Newbie

      i installed an apache server with mod_cluster.


      i used this config


      LoadModule proxy_module /appli/apache2/modules/mod_proxy.so

      LoadModule proxy_ajp_module /appli/apache2/modules/mod_proxy_ajp.so

      LoadModule slotmem_module /appli/apache2/modules/mod_slotmem.so

      LoadModule manager_module /appli/apache2/modules/mod_manager.so

      LoadModule proxy_cluster_module /appli/apache2/modules/mod_proxy_cluster.so

      LoadModule advertise_module /appli/apache2/modules/mod_advertise.so



      <IfModule manager_module>

        Listen adr_server:8796

        ManagerBalancerName mycluster

      <VirtualHost adr_server:8796>

          <Directory />

           Order deny,allow

      #     Deny from all

           Allow from all




          KeepAliveTimeout 300

          MaxKeepAliveRequests 0

          #ServerAdvertise on http://@IP@:6666

          AdvertiseFrequency 5

          #AdvertiseSecurityKey secret

          #AdvertiseGroup @ADVIP@:23364


          <Location /mod_cluster_manager>

             SetHandler mod_cluster-manager

             Order deny,allow

      #    Deny from all

             Allow from all






      but it doesnt work, and i have this message in the apache error log file "[warn] proxy: No protocol handler was valid for the URL /. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule."


      can any bady help me?

        • 1. Re: config apache mod_cluster
          Radoslav Husar Master

          Your mod_cluster seems to be advertizing connections to HTTP but you have only loaded the AJP module for mod proxy (LoadModule proxy_ajp_module /appli/apache2/modules/mod_proxy_ajp.so).


          SO you either need to load this module:

          LoadModule proxy_http_module modules/mod_proxy_http.so 

          Or switch your AS isntallation to use AJP instead of HTTP (I would recommend this option).

          • 2. Re: config apache mod_cluster
            Nossair Faquihi Newbie

            this is what i did in the AS installation :


            <subsystem xmlns="urn:jboss:domain:modcluster:1.0">

                            <mod-cluster-config advertise-socket="modcluster" proxy-list="adr_apache:8796">


                                    <load-metric type="busyness"/>









            <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false" instance-id="server-web1">

                            <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                            <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>

                            <virtual-server name="default-host" enable-welcome-root="true">

                                <alias name="localhost"/>

                                <alias name="example.com"/>





            is that correcte?

            what can i change to switch the AS isntallation to use AJP?


            thanks for your help

            • 3. Re: config apache mod_cluster
              Michal Karm Babacek Apprentice

              Please, update your AS7 and mod_cluster, if you can.

              urn:jboss:domain:modcluster:1.0 suggests you are not really up to date.


              If you set <mod-cluster-config connector="ajp"...

              it will use the connector indicated.

              • 4. Re: config apache mod_cluster
                Nossair Faquihi Newbie

                tkans for your reply

                but how can i update mod_cluster without updating the AS7?

                • 5. Re: config apache mod_cluster
                  Radoslav Husar Master

                  For that you would have to update entire AS7 installation.