2 Replies Latest reply on Mar 13, 2013 3:27 AM by Rama g

    Async IO not working with HTTPEventServlet on Jboss 5.1

    Rama g Newbie

      We are trying to use HTTPEventServlet for a event push to clients Async IO not working with HTTPEventServlet on Jboss 5.1.

       

      We have added following connector tag in server.xml of jbossweb.sar

       

      <Connector  protocol="org.apache.coyote.http11.Http11AprProtocol" connectionTimeout="20000" max-connections="3000" port="80" address="${jboss.bind.address}" redirectPort="443" />

       

       

      We have successfully installed APR connector.  Same is reflecting in console log.

       

      2013-03-12 11:45:02,496 IST  INFO [main] AprLifecycleListener - Loaded Apache Tomcat Native library 1.1.20.

      2013-03-12 11:45:02,496 IST  INFO [main] AprLifecycleListener - APR capabilities: IPv6 [true], sendfile [true], random [true].

      2013-03-12 11:45:02,675 IST  INFO [main] Http11AprProtocol - Initializing Coyote HTTP/1.1 on http-0.0.0.0-80

      2013-03-12 11:45:02,676 IST  INFO [main] AjpAprProtocol - Initializing Coyote AJP/1.3 on ajp-0.0.0.0-8009

       

       

      Attached is the sample code that we are using.

       

       

      After these steps, when we try to invoke the application, it some how doesn't push messages to the web page (even after a writer flush). When the Jboss server is shut down, all the messages stored in the buffer are pumped onto the web page at once. Ideally the application should send out messages asynchronously which isn't happening in my case.

       

       

      Please let me know what could be the issue here.

       

       

      Thanks,

      Rama