1 Reply Latest reply on Apr 1, 2013 11:08 AM by Jesper Pedersen

    Resource adapter deployed without errors but cannot lookup connection factory

    inv3r53 d Novice

      Hi,

       

      I have written a simple resource adapter and deploying it in jboss as 7.1.1.

      But i see no information about jndi binding of the manage connection factory implementation and also no errors reported.

       

      INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found testConnector.rar in deployment directory. To trigger deployment create a file called testConnector.rar.dodeploy

      INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015876: Starting deployment of "testConnector.rar"

      INFO  [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS018559: Deployed "testConnector.rar"

       

      For the hello world example i see the below message

       

      INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-7) JBAS010406: Registered connection factory java:/HelloWorld

      INFO  [org.jboss.as.connector.deployers.RADeployer] (MSC service thread 1-7) IJ020002: Deployed: file:/D:/jboss-as-7.1.1.Final.tar/jboss-as-7.1.1.Final/standalone/deployments/iron_jacamer_sample.rar/

      INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-3) JBAS010401: Bound JCA ConnectionFactory [java:/HelloWorld]

       

      I dont see such a message for my resource adapter and also no errors / warns

       

      what could be possibly missing ? :/

       

       

      Also my iron-jacamar.xml is as below

       

      {code=xml}

      <?xml version="1.0" encoding="UTF-8"?>

      <ironjacamar>

        <connection-definitions>

          <connection-definition class-name="com.MyManagedConnectionFactory" jndi-name="java:/testConnector"/>

        </connection-definitions>

      </ironjacamar>

      {code}

       

      Message was edited by: daedlus D, added log info