2 Replies Latest reply on Apr 5, 2013 11:03 AM by Tom Cunningham

    Helloworld quickstart on macosx

    Ravi Dharnikota Newbie

      I installed the  jboss-soa-p-standalone-5 package on my mac osx. I ran run.sh to start up the server. It started up without any errors. On another terminal I ran the helloworld "ant deploy" which produced output as expected(creation of queues etc). However when I run "ant runtest" it just hangs at

      runtest:

           [echo] Runs Test JMS Sender

       

       

      I don't see anything in the server logs or on the console.

       

      What am I missing ?

       

      I even cheked the queues from the admin console but there does not seem to be any message on the _gw request queue although it does show up as 1 message consumer for that queue.

      Any help/pointer is appreciated.

        • 1. Re: Helloworld quickstart on macosx
          Ravi Dharnikota Newbie

          After waiting for a while I run into this error on the console.

           

          runtest:

               [echo] Runs Test JMS Sender

               [java] Exception in thread "main" javax.naming.CommunicationException: Could not obtain connection to any of these urls: 127.0.0.1:1099 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] [Root exception is javax.naming.CommunicationException: Failed to retrieve stub from server /127.0.0.1:1099 [Root exception is java.io.EOFException]]

               [java]     at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1851)

               [java]     at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:720)

               [java]     at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:713)

               [java]     at javax.naming.InitialContext.lookup(InitialContext.java:392)

               [java]     at org.jboss.soa.esb.samples.quickstart.helloworld.test.SendJMSMessage.setupConnection(SendJMSMessage.java:52)

               [java]     at org.jboss.soa.esb.samples.quickstart.helloworld.test.SendJMSMessage.main(SendJMSMessage.java:81)

               [java] Caused by: javax.naming.CommunicationException: Failed to retrieve stub from server /127.0.0.1:1099 [Root exception is java.io.EOFException]

               [java]     at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:354)

               [java]     at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:287)

               [java]     at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1821)

               [java]     ... 5 more

               [java] Caused by: java.io.EOFException

               [java]     at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2284)

               [java]     at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2753)

               [java]     at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:777)

               [java]     at java.io.ObjectInputStream.<init>(ObjectInputStream.java:277)

               [java]     at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:339)

               [java]     ... 7 more

           

          BUILD FAILED

           

          /jboss-soa-p-standalone-5/jboss-esb/samples/quickstarts/helloworld/build.xml:15: Java returned: 1

           

          Total time: 372 minutes 51 seconds

          • 2. Re: Helloworld quickstart on macosx
            Tom Cunningham Master

            It looks like it can't connect to JNDI - did you wait till SOA-P had completely started up before trying to execute runtest?      Which version of SOA-P are you using?