0 Replies Latest reply on Apr 4, 2013 9:46 AM by erik romson

    problems with JBoss 7.2

    erik romson Newbie

      Hi,

      We recently upgraded from 7.1.1 -> 7.2.0 and were pulling along the arquillian tests.

       

      In the standalone.xml there are a number of changes. When I took the default  standalone/configuration/standalone.xml the container never started.

       

       

      Then I tried with the one that was working for 7.1.1, which works when put into 7.2.0. I then did change by change and the top element stops the server from starting : <server xmlns="urn:jboss:domain:1.4">

      -----------------

      The reason seems to be that in

       

      org.jboss.as.arquillian.container.ManagementClient#isServerInRunningState

       

      the line

       

      ModelNode rsp = client.execute(op);

       

      throws

       

      java.io.IOException: java.net.ConnectException: JBAS012174: Could not connect to remote://localhost:10002. The connection failed

       

      which has cause

       

      "Authentication failed: all available authentication mechanisms failed"

       

      from org.jboss.remoting3.remote.ClientConnectionOpenListener:332

      ------------------

      Reproduce:

      1: Have working environment for 7.1.1

      2: Install Jboss 7.2

      3: run test with standalone.xml file from 7.1.1 in 7.2 server -> ok

      4: in standalone.xml, change <server xmlns="urn:jboss:domain:1.2"> to <server xmlns="urn:jboss:domain:1.4"> -> not ok

       

      ---------------

       

      I have unsuccesfully been trying to find out how to solve this by changing the standalone.xml so that it may work somehow (client connection authentication that is)