3 Replies Latest reply on Apr 5, 2013 2:20 PM by Nicklas Karlsson

    Error deploying to JBoss 7.1.1

    Fernando Martins Newbie

      Hi,

       

      I'm very new to JBoss

       

      I'm trying out JBoss 7.1.1.Final,

       

      I tried the older JDeveloper 10G and everything went fine, even the Remote Debugging, all OK

       

      But now with JDeveloper 11G any build that I'm trying to deploy gives me this error in JBoss :

       

      Caused by: org.jboss.modules.ModuleNotFoundException: Module org.eclipse.persistence:main is not found in local module loader @435a3a (roots: C:\JBoss\jboss-7.1.1.Final\modules)

       

      please can someone help me ? what can I do ? I don't use Eclipse

       

      thank you very much

        • 1. Re: Error deploying to JBoss 7.1.1
          Nicklas Karlsson Master

          I've never used JDev with AS7 (didn't even know it supported it), it sounds more like it's trying to hook in persistence code through some own modules or something. Impossible to know without seeing how it starts up the AS and what it deploys. In any case, it's not an AS issue so I would suggest the JDev forums for a higher success rate in getting help.

          • 2. Re: Error deploying to JBoss 7.1.1
            Fernando Martins Newbie

            What is the best IDE for Jboss ?

             

            We are trying to migrate to JBoss from OC4J

             

            I think I managed to correct the above problem installing eclipselink.jar in [jboss_home]\modules\org\eclipse\persistence\main

             

            but still have problems with persistence givig a new error :

             

             

            16:34:50,967 INFO  [org.jboss.as.server] (HttpManagementService-threads - 1) JBA

            S015870: Deploy of deployment "prod_v0.0.1_iDigital.menu.ear" was rolled back wi

            th failure message {"JBAS014771: Services with missing/unavailable dependencies"

            => ["jboss.persistenceunit.\"prod_v0.0.1_iDigital.menu.ear/iDigital.menu-WebApp

            .war#InfraModel\"jboss.naming.context.java.jdbc.stdDSMissing[jboss.persistenceun

            it.\"prod_v0.0.1_iDigital.menu.ear/iDigital.menu-WebApp.war#InfraModel\"jboss.na

            ming.context.java.jdbc.stdDS]","jboss.persistenceunit.\"prod_v0.0.1_iDigital.men

            u.ear#InfraModel\"jboss.naming.context.java.jdbc.stdDSMissing[jboss.persistenceu

            nit.\"prod_v0.0.1_iDigital.menu.ear#InfraModel\"jboss.naming.context.java.jdbc.s

            tdDS]"]}

             

            the funny thing is that with JDev 10g I didn't have problems

             

            thanks, I will try Oracle forum

            • 3. Re: Error deploying to JBoss 7.1.1
              Nicklas Karlsson Master

              eclipse + jboss tools is a natural solution. some like intellij IDEA