5 Replies Latest reply on Jun 12, 2013 8:18 PM by David Kago

    Did not receive a response to the deployment operation within the allowed timeout period

    dayananda airody Newbie

      We are using JBossAS 7.0.2 Final. We migrated from JBoss4 to JBoss7. After the migration, we are seeing random deployment failures as described in AS7-5080 ( https://issues.jboss.org/browse/AS7-5080 ).

      We have increased the deployment-timeout to 600 seconds. We restart the jboss periodically. During these restarts, deployments are failing randomly. After deployment failure, if I change the extension of war file to .dodeploy, it gets deployed correctly. So, the application seems to be fine.

       

      Below is the error message:

      ----------------------------------------

      00:42:48,487 ERROR [org.jboss.as.deployment] (DeploymentScanner-threads - 1) Did not receive a response to the deployment operation within the allowed timeout period [600 seconds]. Check the server configurationfile and the server logs to find more about the status of the deployment.

      00:42:48,487 ERROR [org.jboss.as.deployment] (DeploymentScanner-threads - 1) Did not receive a response to the deployment operation within the allowed timeout period [600 seconds]. Check the server configurationfile and the server logs to find more about the status of the deployment.

       

      Resolution for

      AS7-5080 ( https://issues.jboss.org/browse/AS7-5080 )

      , says that it is “Out of Date”. What does it mean? Does it mean  it is no longer reproduced in 7.1.1.Final version ? Should we upgrade to 7.1.1 Final version? Did this issue require

      Any code change?

       

       

      I also noticed below NPE exception in log file:

      ----------------------

      00:44:51,772 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Failed to start service jboss.deployment.unit."traqmanage.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."traqmanage.war".PARSE: Failed to process phase PARSE of deployment "traqmanage.war"

      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:121) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1824) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1759) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_35]

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_35]

      at java.lang.Thread.run(Thread.java:662) [:1.6.0_35]

      Caused by: java.lang.NullPointerException

      at org.jboss.as.web.deployment.TldParsingDeploymentProcessor.deploy(TldParsingDeploymentProcessor.java:77)

      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:115) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]

      ... 5 more

       

      -----------------------

       

      There is another exception related to finding Timer Service.

      ------------

       

      01:16:15,803 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/traqmanage]] (MSC service thread 1-1) Exception sending context initialized event to listener instance of class com.traq.manage.web.TraqAppContextListener: java.lang.RuntimeException: Unable to find MBean jboss:service=Timer

      at com.traq.common.util.jboss.JbossScheduler.<init>(JbossScheduler.java:93) [traq-common.jar:]

      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [:1.6.0_35]

      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) [:1.6.0_35]

      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) [:1.6.0_35]

      at java.lang.reflect.Constructor.newInstance(Constructor.java:513) [:1.6.0_35]

      at java.lang.Class.newInstance0(Class.java:355) [:1.6.0_35]

      at java.lang.Class.newInstance(Class.java:308) [:1.6.0_35]

      at com.traq.common.util.SchedulerFactory.getScheduler(SchedulerFactory.java:52) [traq-common.jar:]

      at com.traq.manage.web.TraqAppContextListener.contextInitialized(TraqAppContextListener.java:59) [classes:]

      at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3368) [jbossweb-7.0.1.Final.jar:7.0.2.Final]

      at org.apache.catalina.core.StandardContext.start(StandardContext.java:3821) [jbossweb-7.0.1.Final.jar:7.0.2.Final]

      at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:70) [jboss-as-web-7.0.2.Final.jar:7.0.2.Final]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1824)

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1759)

      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_35]

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_35]

      at java.lang.Thread.run(Thread.java:662) [:1.6.0_35]

       

       

       

      Any help is appreciated. As this is happening randomly, we are not able to reproduce this issue consistently.