2 Replies Latest reply on Apr 22, 2013 9:25 AM by dom_rf

    RichFaces 4.3.0 : IE8 problems

    dom_rf Newbie

      Hi,

       

      RichFaces version: 4.3.0

       

      Application works fine in Chrome, Firefox and IE10, but in IE8 it's not working properly.

       

      In browser mode: "IE8" and document mode: "Normes IE8"

      At each opening screen, IE restore tab: "This tab has been recovered. A problem with this web page caused Internet Explorer to close and reopen the tab."

       

      In browser mode: View compatibility and document mode: "Normes IE7"

      Screen opens correctly, but the menu items (rich:menuItem ) are no longer visible.

      If I click on a command button on the screen (search for example), the screen reload and the menu items are now visible...

       

      Have you ever seen this kind of problems?

      Any idea?

       

      Thanks.

        • 1. Re: RichFaces 4.3.0 : IE8 problems
          dom_rf Newbie

          Hi,

           

          For information, I solved the menu items problem.

          In the file bandeauAvecMenu.xhtml, there was

           

               <h:form>

                    ---

                    <h:panelGrid>

                         ---

                    </h:panelGrid>

                    ---

               </h:form>

           

          that iI changed to:

               <h:panelGrid>

                         ---

                    <h:form>

                         ---

                    </h:form>

                         ---

               </h:panelGrid>

           

          and it works well...

           

          The problem "In browser mode: "IE8" and document mode: "Normes IE8"" is still present...

          If someone has an idea I'm interested!

           

          dom_rf.

          • 2. Re: RichFaces 4.3.0 : IE8 problems
            dom_rf Newbie

            Hi,

             

            To avoid the IE8 problem, I try to use conditional comment to force document mode (quirks, IE7)  like this (my web site must be also compatible with IE6):

             

            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
            <head>
            
            <!--[if lte IE 6]><meta http-equiv="X-UA-Compatible" content="IE=5"/><![endif]-->
            <!--[if (lte IE 8) & (gt IE 6)]><meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /><![endif]-->
            
            </head>
            

             

            but it does not work.

             

            If I put the following simple code, it works:

             

            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
            <head>
            
            <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
            </head>
            

             

            How use conditionnal comment with richfaces?

             

            dom_rf.